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When you create a chart in Microsoft Excel, two new tabs appear on the ribbon 
under the heading Chart Tools. The first of these tabs, Design, offers options 
related to the structure of the chart—the type of chart, the presence or absence 

of various chart elements, the location of the chart, and other similar matters. The second 
new tab, Format, is concerned with the appearance of the chart.

The current chapter and the one that follows adhere more or less to this framework, 
although the distinction between structure and appearance is by no means hard and fast. 
We’ll look first at design issues, and then follow in Chapter 20, “Formatting charts,” with 
matters of format and style. The third chapter in this section—Chapter 21, “Using spark-
lines”—looks at sparklines, miniature charts that you can use to depict data graphically 
within the confines of single worksheet cells.

Selecting data for your chart
The first step in creating a chart is to select some data. If you’re plotting all the cells in a 
contiguous block of cells, you don’t have to select the entire block; select any cell within the 
block, and Excel knows what to do. If, on the other hand, you want to plot only certain rows 
and columns within the range, you need to select those rows and columns explicitly.

Under some conditions, it’s advantageous to set up your source data as a table (by select-
ing a cell within it and pressing Ctrl+T or Ctrl+L) before creating a chart from it:

 ● If you plot data in a table and subsequently add new rows or columns to the table, 
Excel automatically incorporates those rows or columns into the chart.
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 ● If you want your chart to focus on particular rows of data within a large block, a 
table can make that process more convenient. When you convert a range to a table, 
Excel adds filter controls to each column in the range. You can use these controls to 
hide the rows in which you’re not currently interested. For example, you can set up a 
chart that plots the most recent month’s numbers in a table of time-related data or 
the rows that have the top 10 values in some column of interest. Note, however, that 
when you change or remove the filter, Excel adjusts the chart so that it plots the vis-
ible rows. To make a permanent plot of particular rows in a range, select those rows 
explicitly without filtering the range. (You can plot noncontiguous rows by holding 
down Ctrl while you select each one.)

 ● If you want your source data and chart to have consistent or complementary format-
ting characteristics, you can achieve that more easily using table styles and chart 
styles.

For information about tables, see Chapter 22, “Managing information in tables .” For informa-
tion about chart styles, see “Choosing a chart style” later in this chapter .

Creating a new chart
When you have selected the data you want to chart, click the Insert tab. The Charts group 
on the ribbon appears in the center of the ribbon, presenting you with an assortment of 
chart-type buttons. You can go straight to the options for creating a particular kind of chart 
by clicking that chart-type button. For example, if you know you want a column chart, you 
can click the Column Chart button to see a set of options related to that chart type:

The gallery that unfolds presents a set of subtype options—various kinds of stacked and 
unstacked two-dimensional column charts, for example, as well as a selection of three-
dimensional possibilities—and you can see still more choices by clicking the More… button 
at the bottom of the gallery.
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In many cases, you will find it simpler to skip this gallery and click Recommended Charts 
instead. Microsoft made that item the largest button in the Charts group; you can’t miss 
it. The Insert Chart dialog box that appears when you click Recommended Charts presents 
a gallery of potentially suitable chart types and provides a preview of what your data will 
look like in each of these offerings:

Scroll through the options on the left side of this dialog box until you find one that’s right 
for your data. Of course, Excel won’t always understand your data well enough to provide 
suitable options in the Recommended Charts gallery; if you don’t find what you need there, 
click on the All Charts tab in the Insert Chart dialog box to see the full range of chart type 
options.

When you click OK, Excel plants a chart object on your worksheet, as shown in Figure 19-1. 
A chart object is a graphic element that lies atop your worksheet in its own window. You 
can drag any part of the object’s perimeter to move it or drag one of the handles in the 
corners or midpoints of the sides to change the object’s size. As you’ll see, you also have 
the option of turning the chart object into a separate chart sheet.
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Figure 19-1 A chart object floats atop your worksheet.

With your chart selected, Excel adds two tabs to the ribbon under the heading Chart Tools 
and selects the first of these tabs, Design. You can see the appearance of the Design tab at 
the top of Figure 19-1. The centerpiece of the Design tab, the Chart Styles group, provides 
lots of alternatives for the basic appearance of your chart. If the ones you see immediately 
on the ribbon don’t give you the look you require, click the arrow in the lower right corner 
of the group to see an expanded set:

Notice that you do not have to actually select one of these items to see its effect; simply 
hover the mouse over a choice and Excel will give you a preview.
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Note
The ribbon presents a different set of options, including an Analyze tab, if the selected 
chart is a PivotChart . Because PivotCharts are inextricably connected with PivotTables, 
we discuss them separately in Chapter 23, “Analyzing data with PivotTable reports .” See 
“Creating PivotCharts” in Chapter 23 .

The buttons on the Design tab, from Add Chart Element on the left to Move Chart on 
the right, focus on basic structural issues relating to your chart. You can use them, among 
other tasks, to add, format, or remove titles, legends, or axes; to swap rows and columns; or 
to remove particular values from the chart. The Format tab, shown next, lets you do such 
things as add arrows, shapes, and descriptive text.

Notice that when a chart object is selected, Excel displays three customizing buttons next 
to the upper right corner of the chart:

These buttons—Chart Elements, Chart Styles, and Chart Filters—are new in Excel 2013 and 
offer some alternatives to the ribbon for common chart-formatting tasks. They’re handy, 
particularly if you like to work with the ribbon out of sight. If you don’t see the buttons 
when a chart object appears to be selected, click the chart again; the buttons sometimes 
disappear when you move a chart, even though the chart remains selected, but they’ll 
reappear when you click.
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Changing the chart type
If you didn’t get the chart type you were expecting, select the chart and click Change Chart 
Type on the Design tab of the ribbon. The Change Chart Type dialog box, shown next, pro-
vides access to all the chart types that Excel can create.

The row of buttons across the top of this dialog box represent subtypes of the selected 
type; in the figure just shown, for example, the button on the left end of that row offers 
clustered-column options; the next one to the right presents stacked columns, and so 
on. Hover your mouse over any of the charts shown in the main part of the dialog box to 
obtain a magnified view.

Using a combo chart type

A combo chart is one in which one or more data series are plotted in a chart type different 
from that of the remaining series. Combo charts are particularly useful when one of the 
series is qualitatively different from the others. In the following clustered column chart, for 
example, the series labeled Average is different in kind from the other series, each of which 
represents an individual person:
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Plotting the Average series as a line instead of a column improves the readability of the 
chart, allowing you to see at a glance who is and isn’t above average:

With some data sets, Excel will recognize that a combo chart is appropriate and will pro-
pose it in the Recommended Charts gallery. If that doesn’t happen, however, you can 
always change a single-type chart to a combo at any time. Select the chart, click Change 
Chart Type, and then choose Combo in the list of chart types at the left side of the dialog 
box. Select one of the chart pictures at the top of the dialog box, above the preview win-
dow, and then work with the options in the bottom of the dialog box to get the combina-
tion of types that you want. In the following dialog box, for example, you can see that Excel 
has correctly intuited that the Average series should be a line, but it has incorrectly pro-
posed to plot Herbinger as a line as well.
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You can fix that by selecting Clustered Column in the drop-down list next to Herbinger.

Assigning a series to a secondary axis
A secondary value axis makes it possible to compare data series that fall within divergent 
ranges. The secondary axis, positioned at the right, can have a completely different scale 
from the primary axis. You can assign as many series as you like to the secondary axis.

In the following chart, for example, the Cost Per Square Foot numbers are so small in 
comparison with the Median Square Footage numbers that no useful comparisons can be 
made:



Ch
ap

te
r 1

9

 Assigning a series to a secondary axis 675

Plotting the two series on separate axes provides more useful information. To move a series 
to another axis, you can right-click it, choose Format Data Series, and then choose Second-
ary Axis in the task pane that appears. Alternatively, you can select any part of the chart, 
click Change Chart Type, select Combo, and then work with the options at the bottom of 
the Change Chart Type dialog box. As the following illustrates, the Change Chart Type dia-
log box lets you see the effect of your customization before you click OK:
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Switching rows and columns
Most of the time when you present a block of data to Excel for charting, the program fig-
ures out correctly how to organize that data—which labels to assign to the horizontal axis 
and which to put in the chart’s legend. Because this might not always be the case, however, 
the program offers a Switch Row/Column button in the Data group of the Design tab. 
Clicking that button, for example, transforms this chart:
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into this one:

In the first example, each data cluster represents a year, and the various column col-
ors (identified in the legend) represent cities. In the second example, this orientation is 
reversed.
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Choosing a chart layout
What Excel calls a chart layout is a combination of choices affecting such elements as the 
chart’s title, legend, axes, axis titles, and gridlines. Each of the program’s chart types comes 
with an assortment of packaged layout options. With the chart selected, you can see the 
available layouts by clicking the Quick Layout button in the Chart Layouts group of the rib-
bon. Here, for example, are the layouts provided for a line chart:

Don’t be dismayed by the tiny boxes; hover the mouse, and Excel will preview your selec-
tion on the worksheet. And don’t worry if none of the built-in layouts gives you the combi-
nation and positioning of chart elements that you’re looking for. You can always tailor those 
elements with individual formatting commands.

Choosing a chart style
A chart style is a combination of foreground and background colors designed to coordinate 
with cell styles, shape styles, and table styles to give your workbook a consistent, profes-
sional, and high-impact appearance. To apply a chart style, select the chart and then click 
Design under Chart Tools on the ribbon. The Chart Styles group shows you a half-dozen 
or more choices, depending on your screen resolution. To see more, click the arrow at the 
lower right corner of the group.

Chart styles let you do such things as apply attractive gradient fills to your chart back-
grounds, add photorealistic highlighting to bar and column markers, switch line-chart 
markers from fat to svelte, and so on. The best way to see the wealth of possibilities is to 
select a chart, open the gallery, and experiment.
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Note that cell styles, table styles, and chart styles are all components of the current theme. 
That is, when you change the theme applied to your workbook (by clicking Page Layout 
on the ribbon and opening the Themes gallery at the left side of the ribbon), your avail-
able cell styles, table styles, and chart styles all change as well. Also, be aware that theme 
changes on your computer do not affect the appearance of your chart on someone else’s 
computer; if your chart is full of pink, it might still look green to your coworker.

For more information about themes, see “Formatting with themes” in Chapter 9, “Worksheet 
formatting techniques .” For more information about cell styles, see “Formatting with cell 
styles” in Chapter 9 . For more information about table styles, see “Customizing table styles” 
in Chapter 22 .

Moving the chart to a separate chart sheet
If you don’t need to have your chart next to the numbers from which it is derived, you 
might consider putting it on its own chart sheet. A chart sheet is a separate, special- 
purpose sheet that gives the maximum amount of screen area to your graph. To move your 
chart from a worksheet to a chart sheet, right-click on the chart border or the plot area and 
choose Move Chart (or select the chart and then click Move Chart on the Design tab). In 
the dialog box that appears, select New Sheet, supply a name for the chart sheet or accept 
the default name, and then click OK. If you decide to move the chart back to the work-
sheet, repeat this process, select Object In, select the name of the worksheet you want to 
move the chart to, and then click OK.

INSIDE OUT   Press F11 to move a chart

You can move a chart object to a chart sheet by selecting the chart and pressing F11 . 
The only disadvantage to this approach is that you don’t get to name the chart sheet . 
But you can always do that later by double-clicking the sheet tab and changing the 
default name to something of your choosing . You can even create a chart on a chart 
sheet directly from data—by selecting a cell or range and pressing F11 . Here the one 
disadvantage is that Excel uses the current default chart type, which might not be what 
you want . But you can always switch to a different type by selecting the chart on the 
chart sheet and clicking Change Chart Type .
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Adding, editing, and removing a chart title
If your chart doesn’t already have a title, you can add one by selecting the chart and doing 
either of the following:

 ● Click the Chart Elements button next to the upper right corner of your chart, and 
then select the Chart Title check box. Excel displays a title with default text, centered 
above the plot area. To display the title near the top of the chart but within the plot 
area, click the arrow that appears when you hover the mouse over Chart Title in the 
Chart Elements list, and then choose Centered Overlay on the submenu that appears.

 ● Click the Design tab, click Add Chart Element, click Chart Title, and then select either 
Above Chart or Centered Overlay. Excel displays a title with default text, in the posi-
tion you selected.

If you selected Above Chart, Excel positions the title above the plot area, in some cases 
shrinking the plot area just enough to make room for the title. If you selected Centered 
Overlay, Excel centers the title near the top of the chart without adjusting the plot area. This 
option gives you a little more room for your vertical axis, gridlines, and chart markers, but 
in some cases it might make the title or the markers hard to read. The title is a floating text 
object in any case; you can select it and drag it anywhere within the chart area.

To edit a chart title, select it and type. When you press Enter, your text replaces the current 
title. To use the value of a worksheet cell as the title, type an equal sign, point to the cell, 
and press Enter. If that’s awkward to do—for example, if the text you want to cite is not in 
sight—type a worksheet-qualified reference to the cell in question. To grab the text from 
cell A4 on Sheet1, for example, you could type =sheet1!A4. Note that the formula must 
include the sheet name, even if the text is on the same sheet as the chart.

To make the title text bold or italic, you can select the title and press Ctrl+B or Ctrl+I. For 
more elaborate font changes—for example, to choose a different typeface or size—select 
the title, right-click, and then choose Font from the shortcut menu.

To change the appearance of individual words or characters in a title, select the title and 
then click within the title to get an insertion point. Select the text you want to format, and 
then choose Font. (To select a particular word, double-click that word.) If for any reason 
you’re having trouble getting the insertion point, right-click the title and choose Edit Text.

Excel will automatically break a long title into two centered lines. If you don’t like where the 
break comes, or if you want to break a short title into multiple lines, position the insertion 
pointer where you want a line break and then press Shift+Enter.

To delete a title, simply select it and press the Delete key.
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Note
Additional options for customizing chart titles are available via the Format Chart Title 
task pane . To display the task pane, choose More Options on the Chart Title submenu, 
or click Add Chart Element on the ribbon, choose Chart Title, and then choose More 
Title Options . We discuss these additional options in Chapter 21 in the following sec-
tions: “Formatting lines and borders,” “Formatting areas,” and “Formatting text .”

Adding, editing, and removing a legend
The steps for adding, editing, and removing a legend are essentially the same as those for 
working with a chart title. For details, see the previous discussion.

You can choose to position a legend at the top, left side, right side, or bottom of the chart 
area. Like the chart title, the legend is a floating text object; you can drag it to any suitable 
location within the chart area.

Excel uses either column headings or row headings within your chart’s data block as default 
legend text. (If there are no such headings, it uses dummy text, such as “Series 1” and 
“Series 2.”) You can change the legend text by editing the column or row headings. If by 
chance you want something in the legend different from what you have on the worksheet, 
select the chart, click the Design tab on the ribbon, and then click Select Data. Suppose, 
for example, that your data block uses spelled-out month names, but using those names 
makes for a bulky, two-line legend. The foregoing steps would take you to the Select Data 
Source dialog box, shown next:
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Here you could select month names, click Edit, and supply the shortened versions you 
prefer.

Adding and positioning data labels
You can add data labels to all series in a chart by selecting the chart, clicking the Chart 
Elements button, and selecting the Data Labels check box. The submenu includes a set of 
positioning options geared to the type of chart. With some charts, you might find a Best Fit 
option; as Figure 19-2 shows, this option can be handy on pie charts with narrow slices.

Figure 19-2 If you choose Best Fit for this chart’s data labels, Excel doesn’t try to fit the label 
2383 into the narrow slice but displays it outside the pie instead.

Adding a data table
A data table is a copy of your source data included within the chart. Data tables are useful 
particularly when the chart and its underlying data are not in close proximity on the work-
sheet or when you intend to copy the chart to a Microsoft Word or PowerPoint document. 
To add a data table, select the chart, click the Chart Elements button, and select the Data 
Table check box. You can use the available options to choose between having and not hav-
ing legend keys with your table.

Adding and removing gridlines
To add or remove gridlines, click the Chart Elements button and select or clear the Gridlines 
check box. The submenu that appears when you click the arrow to the right of the Gridlines 
check box gives you finer control; for each axis on the chart, you can select either major 
gridlines, minor gridlines, or both. Excel previews the effects of these choices as you hover 
the mouse pointer over the check boxes.
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Be aware that major gridlines in certain kinds of three-dimensional charts can make data 
points appear to have less than their true value. In the following illustration, for example, 
the data points have exact integer values from 1 to 10, but the gridlines, in combination 
with the three-dimensional perspective, make each point appear somewhat smaller.

Adding and editing axis titles
To add axis titles to a chart, select the chart, click the Chart Elements button, and select the 
Axis Titles check box. To add or delete a title for a particular axis only, click the arrow to 
the right of the Axis Titles check box and then clear or select the check box for the axis in 
question.

Excel initially uses default text for axis titles. You can edit that text in the same manner that 
you edit chart title text; for details, see “Adding, editing, and removing a chart title” earlier 
in this chapter.

Working with axes
To display or suppress one or more chart axes, select the chart and click the Chart Elements 
button. You can make all the axes disappear or reappear by clearing or selecting the Axes 
check box. To manipulate a particular axis, click the arrow to the right of Axes in the Chart 
Elements list.

If you’re an Excel veteran, you might have seen the terms category axis and value axis in 
some older versions of the product. Excel now uses the more commonplace descriptions 
horizontal and vertical. It’s worthwhile understanding why the older terms were used, how-
ever. A value axis is one that is scaled numerically. Value axes are generally vertical (except 
in bar charts, which are essentially column charts rotated 90 degrees), but in an X Y (scat-
ter) chart, both the vertical and horizontal axes are value axes. A category axis is delineated 
either by labels that have no numeric significance or by dates.
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Changing the scale of a value axis
The easiest way to manipulate the scale of a value axis is to double-click it. That brings up 
the Format Axis task pane, shown in Figure 19-3. (The values exemplified in Figure 19-3 are 
derived from the chart shown in Figure 19-1 earlier in this chapter.)

Click here to display Axis Options

Figure 19-3 Double-clicking an axis displays its formatting task pane, in which, among other 
things, you can adjust the axis’s scale.

By entering new values in the Minimum and Maximum text boxes, you can override Excel’s 
default choice of axis boundaries.

Changing the positions of tick marks and gridlines

The Major and Minor boxes below the heading Units determine the spacing between tick 
marks—and hence between gridlines. If your axis labels or your gridlines are too close 
together, type new values in those boxes. The Minor Units value is relevant only if you 
choose to display minor tick marks.

Changing the point where axes intersect

By default, axes intersect at the minimum value on the vertical axis scale. You can move the 
intersection to a different point by typing a new value in the box next to Axis Value, below 
the heading Horizontal Axis Crosses. You can also move the intersection to the highest 
point on the value axis by selecting Maximum Axis Value. On a typical chart with a vertical 



Ch
ap

te
r 1

9

 Working with axes 685

value axis and a horizontal category axis, that would put the category axis at the top of the 
chart (unless you also select Values In Reverse Order).

Reversing the value-axis scale

You can turn the value-axis scale upside down so that the higher values appear near the 
bottom of the chart. You might find this option convenient if all your chart values are nega-
tive and you’re interested primarily in their absolute value. To invert the scale, select Values 
In Reverse Order.

Using logarithmic scaling

To use logarithmic scaling, select the Logarithmic Scale check box. If you want to use a base 
other than 10, type that base in the box to the right.

In a logarithmic scale, the lowest value is 1. You cannot plot negative and 0 values. If you 
apply logarithmic scaling to a chart that includes negative or 0 values, Excel displays an 
error message and removes the points that it cannot plot. You can restore those points by 
returning to linear scaling.

Applying a scaling factor

To facilitate the plotting of large numbers, Excel lets you scale your value axis in units rang-
ing from hundreds to trillions. When you choose one of these options, you might also want 
to ensure that the Show Display Units Label On Chart check box is selected so that it will be 
clear that a scaling factor has been applied.

Changing the display format of a value axis

By default, Excel displays numbers on the value axis in the same format as the worksheet 
cells from which those numbers are derived. If you want something different, you can go 
back to the worksheet and change the format there. Alternatively, you can click Number 
in the Format Axis task pane, and then open the Category drop-down menu. The options 
available there are the same as those for formatting worksheet numbers; for details, see 
“Formatting in depth” in Chapter 9.

For more about formatting value axes, see “Formatting axes,” in Chapter 20 .

Changing the scale of a category axis
Excel recognizes two kinds of category axes—those that have ordinary text labels and those 
whose labels are dates. If the axis labels are dates, Excel ordinarily applies time-scaling to it; 
that is, it spaces the labels and data according to their temporal positions. To take a simple 
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example, if you plot a column chart for dates at the beginning of April, May, August, and 
September, Excel gives you something that looks like this:

The markers for August and September are moved to the positions they would occupy 
if data for June and July were included—and, in fact, Excel creates labels for the missing 
dates, perhaps on the assumption that you will supply the missing data later. Excel will also 
sort the chart in chronological order in the event that the worksheet data is not sorted.

Ordinarily, Excel knows whether an axis should be time-scaled or not and proceeds accord-
ingly. As the following illustration shows, Excel’s default Axis Type option is Automatically 
Select Based On Data:

There might be occasions when you want to override Excel’s decision and convert a date 
axis to a text axis. In the preceding example, if you don’t intend ever to fill in the missing 
months, you might prefer an evenly spaced, text-based chart, which would look like this:
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To convert a date-scaled category axis to a text-based one, display the Format Axis task 
pane (double-click the axis to get there) and choose Text Axis.

Changing the beginning and end points on a date axis

By default, Excel makes your earliest time value the minimum point on the scale and the 
latest time value the maximum. By specifying different values for those boundary param-
eters, you can zoom in on a subset of your data. For example, if your chart plots monthly 
information from January through December, you can focus on the third quarter by chang-
ing the Minimum value to 7/1 of the year in question and the Maximum value to 9/30. Fur-
thermore, if you want to stress that the future is unknown, you can extend the maximum to 
a date beyond the date of your last data point. Excel then compresses the plot into the left 
side of the chart, leaving space on the right.

To change the end points of a time-scaled chart, use the Bounds section of the Format Axis 
task pane:

The Major setting under Units determines the spacing of major tick marks, axis labels, and 
major gridlines. To move labels and gridlines farther apart, increase the Major value. The 
Minor setting under Units determines the spacing of minor tick marks and minor gridlines.
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Note
On a time-scaled chart, Excel plots data in chronological order even if it’s not sorted by 
date on the worksheet . We don’t recommend randomizing your data, but it’s interest-
ing to know that the Excel charting engine doesn’t object .

Changing the base unit

On charts with date axes, Excel can plot data points only at intervals of the base unit. 
The available base units are Days, Months, and Years. Excel decides what base unit to use 
according to the smallest difference in value between points in your source data. In other 
words, the program usually knows what to do and usually gets it right. You might occasion-
ally find it convenient to overrule, however.

For example, Figure 19-4 plots daily price data using the automatically determined base 
unit of Days. Switching the base unit to Months or Years (Figures 19-5 and 19-6, respec-
tively) turns the simple daily line chart into an open-high-low-close chart that shows the 
variation of prices over larger time intervals.

Figure 19-4 With the base unit set to its automatically determined value, Days, Excel generates a 
simple line chart of daily prices.
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Figure 19-5 Changing the base unit to Months creates a monthly open-high-low-close chart.

Figure 19-6 Switching the base unit to Years creates yearly bars.

Unfortunately, Excel offers only three base unit choices—Days, Months, and Years. Thus, 
if your data provides, say, hourly price points, you will get a daily chart regardless. If you 
prefer an ordinary line chart showing hourly price progressions, your recourse is to turn off 
date scaling in favor of a text category axis.
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Note
Fiddling with the base unit value is not the only way to get open-high-low-close charts! 
Excel offers four types of stock charts, including open-high-low-close candlesticks . 
To see the choices, click the Insert tab on the ribbon and then click Other Charts . The 
stock charts, listed in the gallery under the heading Stock, require you to set up your 
data in columns—for example, with separate columns for Open, High, Low, and Close . 
The methods described in this chapter are useful to know about when your data is not 
arrayed as required for the built-in stock chart types .

Modifying a chart’s data
The simplest way to add new data points to an existing series on a chart is to make the 
chart’s source range a table (select any cell within the range, and press Ctrl+T; for more 
information, see “Creating a table,” in Chapter 22) and then add new rows to the table. 
Excel incorporates these rows into the chart without requiring you to do anything further.

If you add a new column immediately to the right of a table, Excel expands the table to 
include the column. If you’ve created a chart from such a table, the new column becomes 
a new data series. That might or might not be desirable, depending on the contents of the 
new column. If you find yourself with an unwanted new series, you can delete it by select-
ing the series on the chart and pressing the Delete key. Alternatively, you can use the Filter 
button to remove it. (See “Filtering chart data,” later in this chapter.)

Using the mouse to add data points
If you choose not to make your source data a table, you can still use your mouse to add 
data points to an existing chart series. Figure 19-7 shows a candlestick chart that plots data 
through May 2. Notice that because the chart area is selected, Excel draws two rectangles 
around the source data. The first rectangle, in column A, outlines the range that the chart is 
using for its category axis labels. The second, encompassing columns B through E, outlines 
the four data series. Excel uses magenta for the first rectangle and blue for the second to 
help you distinguish between the two.
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Figure 19-7 When you select the chart area, Excel outlines the source data on your worksheet. 
You can drag a fill handle to alter the source range.

To extend the chart so that it includes the data in rows 750 through 755, drag the fill 
handle in the bottom right corner of either rectangle. Be sure to drag the fill handle, not 
the bottom of the rectangle, if you intend to add data. Dragging the edge of the rectangle 
moves the data selection without changing its size. Dragging the bottom down five rows in 
Figure 19-7, for example, would move both the start date and the end date forward.

Filtering chart data
The Filter button to the right of a chart provides an easy way to suppress the display of par-
ticular series or categories items on that chart. In Figure 19-8, for example, you can remove 
certain cities or years from the chart by clearing their associated check boxes. The Filter 
button also gives you an easy way to focus attention on a particular element of the chart 
without actually changing the chart. When you hover the mouse over an item, as we have 
hovered over Bloomington in the figure, Excel displays the rest of the chart in pale colors 
so that your attention is drawn to a particular data series. As soon as you move your mouse 
from the item you’re hovering over, the chart resumes its normal appearance.
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Figure 19-8 With the Filter button you can easily remove a particular series from a chart or 
simply highlight a series temporarily.

Plotting noncontiguous source ranges
There might be times when the data you want to plot does not lie in a contiguous block 
of cells. Suppose, for example, that from the following table you want to generate a col-
umn chart that compares Petra Chvojkova with Andrej Koklic, omitting the other five 
salespersons:

The simplest way to do this is to use the filter control next to the Salesperson heading to 
restrict the table to Chvojkova and Koklic. Excel responds by hiding rows 2, 4, 5, 7, and 8, 
and any chart generated from the table will plot only the visible rows. If you don’t have 
filter controls, you can accomplish the same feat by manually hiding the rows you want to 
omit using the Format command in the Cells group of the Home tab.
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You can also plot noncontiguous data by pressing Ctrl and selecting the rows or columns 
you want to plot. In this example, you could hold down Ctrl, select rows 1, 3, and 5, and 
then click the appropriate command in the Charts group on the Insert tab. If you use this 
method, be sure to include the header row (row 1 in this example) in your selection so that 
Excel can provide appropriate labels for your chart series.

Changing the way Excel plots empty and hidden cells

Excel ordinarily plots empty cells as gaps—that is, it doesn’t plot them. It also omits cells in 
hidden rows and columns. As Figure 19-9 shows, you can change both defaults if you want. 
The alternatives for empty cells are to plot them as zeros or to fill the gap with a straight 
line. The latter option is available only in line and X Y (scatter) charts.

Figure 19-9 By default, Excel omits missing data in a source range and ignores data in hidden 
rows and columns.

Hidden and empty cell settings are chart-specific. To modify the behavior for a particular 
chart, right-click the chart and click Select Data. Then click Hidden And Empty Cells.

Adding moving averages and other trendlines
A trendline is a line that describes the general tendency of a data series. It can be a mov-
ing average, linear-regression line, or line generated by one of various kinds of nonlinear, 
curve-fitting methods.

To plot a trendline for a particular series, click on any chart marker for the series and then 
click the Chart Elements button. If you select the Trendline check box, Excel will use the 
default trendline type. To see additional options, click the arrow to the right of Trendline. 
The submenu will offer Linear, Exponential, Two Period Moving Average, and More Options. 
Clicking More Options opens the Format Trendline task pane, shown in Figure 19-10. (If you 
don’t see the set of options shown in Figure 19-10, click the third button beneath the head-
ing Trendline Options.)
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Figure 19-10 Using the Format Trendline task pane, you can add six types of trendlines to a data 
series.

To specify the type of trendline or moving average you want, select one of the six options 
at the top of the task pane. If you choose Polynomial, indicate the highest power (from 2 
through 6) for the independent variable in the adjacent Order text box. If you select Mov-
ing Average, indicate the number of periods Excel should use in its calculations.

After you choose the type of trendline you want, you can use the Trendline Name area of 
the task pane to customize the name that appears in the chart’s legend. Options under 
Forecast (not available for moving averages) let you extrapolate the trendline. If you’re 
adding a linear, polynomial, or exponential trendline, you can also select the Set Intercept 
check box to use a y intercept and then specify the y-intercept value in the box on the 
right. Select the Display Equation On Chart and Display R-Squared Value On Chart check 
boxes to display the regression equation and R-squared value on the chart.

Adding error bars
When you plot statistical or experimental data, it’s often helpful to indicate the confidence 
level of your data. The error-bar feature makes this easy. To add error bars to a data series 
in an area, bar, column, line, or X Y (scatter) chart, select the series, click the Chart Elements 



Ch
ap

te
r 1

9

 Adding error bars 695

button, and then click the arrow next to Error Bars. As with trendlines, you can see the full 
set of available options by choosing More Options. Figure 19-11 shows the Format Error 
Bars task pane that appears.

Figure 19-11 You can customize error bars for direction, style, and amount.
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CHAPTER 20

Formatting charts

In Chapter 19, “Designing charts,” you saw the basic procedures for setting up a chart in 
Excel, as well as those for adding titles, axes, gridlines, data labels, and so on. As you’ll 
recall, when you create and select a chart object, Excel adds a Chart Tools heading to 

the ribbon, with two tabs—labeled Design and Format—subordinate to that new head-
ing. Virtually all of the procedures described in Chapter 19 are accessible via the Design 
tab—although, as always in Excel, there are alternative ways to get the job done that don’t 
involve a trip to the ribbon.

In this chapter, we look at issues of style and appearance, aspects of the charting interface 
that are accessible via the Format tab, and associated formatting task panes.

Formatting charts with the Chart Styles gallery
Before you get too involved with the kinds of formatting procedures described later in this 
chapter, however, be sure to familiarize yourself with the Chart Styles gallery, located in 
the middle of the Design tab when a chart is selected. The gallery typically offers a dozen 
or more combinations of structural details and formatting choices tailored to the selected 
graph; click the arrow in the lower right corner of the gallery to see the entire set of offer-
ings. You can preview the effect of each style on your chart by passing your mouse through 
the gallery. Here’s what the gallery might look like for a simple line chart:

Some of the styles have gridlines, while others do not; some have compound lines, some 
have data labels, and some have background colors. (If you want a background color but 
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