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CHAPTER 7

How to work a workbook

in earlY verSionS of Microsoft Excel, worksheets, charts, and macro sheets were stored as 
separate documents. Since Excel 5, however, all these types of data—and more—peace-
fully coexist in workbooks. You can keep as many worksheets containing as many differ-

ent types of data as you want in a workbook, you can have more than one workbook open 
at the same time, and you can have more than one window open for the same workbook. 
The only limitations to these capabilities are those imposed by your computer’s memory 
and system resources.

Managing multiple workbooks
This chapter describes how to protect workbooks, how to use more than one workbook at a 
time, and how and why to split your view of a workbook into multiple windows. Generally, 
when you start Microsoft Excel 2013, a blank workbook appears with the provisional title 
Book1. The only exceptions occur when you start Excel by opening an existing workbook 
or when you have one or more Excel files stored in the XLStart folder so that they open 
automatically.

If you start Excel and then open an existing Excel file, Book1 disappears unless you edited 
it. You can open as many workbooks as you like until your computer runs out of memory.

For more about working with multiple windows, see “Opening multiple windows for the 
same workbook” later in this chapter . For more information about the XLStart folder, see 
“Opening files when you start Excel” in Chapter 2, “Exploring Excel fundamentals.”

Navigating between open workbooks
If you have more than one workbook open, you can activate a particular workbook in any 
of the following ways:

 ● Click its window, if you can see it.

 ● Press Alt+Tab, which activates the next open window (including any non-Excel 
 windows you have open).
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 ● If you have all your workbook windows maximized, you can shuffle through the open 
workbooks by pressing Ctrl+Tab to activate each workbook in the order you opened 
them. Press Shift+Ctrl+Tab to activate them in reverse order.

 ● On the View tab on the ribbon, click a window name on the Switch Windows menu, 
which lists as many as nine open workbooks or, if you have more than nine open, 
displays a More Workbooks command that presents a dialog box listing all the open 
workbooks.

Arranging workbook windows
To make all open workbooks visible at the same time, click the View tab and click Arrange 
All. Excel displays the Arrange Windows dialog box, shown in Figure 7-1, which also 
shows the workbooks arranged in the Tiled configuration with the screen divided into a 
patchwork of open documents. Figure 7-2 shows the same workbooks in the Horizontal 
configuration.

You’ll find the 2014Projections.xlsx, Humongous.xlsx, Team Sales.xlsx, Regional Sales.xlsx, 
and NorthwindSales.xlsx files with the other examples on the companion website.

Figure 7-1 Clicking View, Arrange All opens the Arrange Windows dialog box, which gives you a 
choice of configurations.

If you select the Windows Of Active Workbook check box in the Arrange Windows dialog 
box, only the active workbook is affected by the configuration setting, and then only if 
more than one window is open for the active workbook. Excel arranges those windows 
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according to the option you select under Arrange in the Arrange Windows dialog box. This 
is handy if you have several workbooks open but have multiple windows open for one of 
them and want to arrange only these windows without closing the other workbooks.

Note
Note that the Save Workspace command, which used to be in the Window group on 
the View tab, is no longer available in Excel 2013, because of its new single document 
interface (SDI) behavior . For more information, see the Inside Out tip “Microsoft and 
the SDI” in Chapter 2 .

Figure 7-2 These windows are arranged in the Horizontal configuration.

Note that in the horizontal configuration shown in Figure 7-2, Excel hides the ribbons auto-
matically, which is handy, because you would see nothing but the ribbon in each workbook 
window if it didn’t hide them. To reveal a ribbon, double-click the title bar of any of the 
workbooks.

Note
When you save a workbook, Excel also saves its characteristics, such as the window’s 
size, position on the screen, and display settings . The next time you open the work-
book, the window looks the same as it did the last time you saved it . When you open it, 
Excel even selects the same cells you had selected when you saved the file.
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Comparing worksheets side by side
The Arrange All button on the View tab is extremely helpful if you need to compare the 
contents of two similar workbooks, but another feature makes this task even easier. The 
View Side By Side button essentially packages the Horizontal window arrangement option 
with a couple of useful features to make comparison chores a lot easier. The View Side By 
Side button lives in the Window group on the View tab; it is the top button located to the 
right of the New Window command, as shown in Figure 7-3. 

Figure 7-3 If more than two windows are open, select one in the Compare Side By Side 
dialog box.

Note
The ribbon on your screen might look different from what you see in this book . The 
ribbon’s display adjusts to the size of your screen, its resolution, and the size of the 
Excel window . For example, the six buttons in the middle of the Window group on the 
View tab might or might not display adjacent text labels, depending on your screen’s 
size and resolution and whether Excel is maximized .

You can click the View Side By Side button to arrange any two open windows even if they 
are windows for the same workbook (as described in the next section). But unlike the 
Arrange button, View Side By Side performs its trick on no more or less than two windows. 
After you click the button, you see a Compare Side By Side dialog box like the one shown 
in Figure 7-3 if you have more than two windows open. If so, select the window you want 
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to compare, and click OK; this opens the window and arranges it along with the window 
that was active when you clicked View Side By Side. (The button name is a little bit mislead-
ing because the windows are actually arranged horizontally—not really “side by side,” but 
one above the other.)

After you activate “side-by-side mode,” the two buttons below the View Side By Side but-
ton become active, as shown here and in Figure 7-4:

The Synchronous Scrolling button locks the two windows together wherever they happen 
to be; when you scroll in any direction, the inactive window scrolls in an identical fashion. 
This action is activated automatically when you turn on the View Side By Side feature. The 
Reset Window Position button puts the active window on top, which is handy. The window 
that is active when you first click the View Side By Side button is the one that appears on 
top. If you want the other window on top, click anywhere in the other window, and then 
click the Reset Window Position button to place it in the top position.

Figure 7-4 The Synchronous Scrolling button locks side-by-side window scrolling.
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The View Side By Side button is a toggle. To turn off side-by-side mode and return to Nor-
mal view, click the View Side By Side button again. Make sure you turn it off before moving 
on to other tasks to avoid some odd window behavior.

Opening multiple windows for the same workbook
Suppose you’ve created a workbook like the one shown in Figure 7-5. You might want to 
monitor the cells on the summary worksheet while working on one of the other worksheets 
in the workbook. On the other hand, if you have a large worksheet, you might want to keep 
an eye on more than one area of the same worksheet at the same time. To perform either 
of these tasks, you can open a second window for the workbook by clicking New Window 
on the View tab.

Figure 7-5 We want to view the summary worksheet while working on a supporting worksheet 
in the same workbook.

To view both windows on your screen, click View, Arrange All and then select any of the 
Arrange options except Cascade. If you select the Cascade option, you’ll be able to view 
only the top worksheet in the stack. If you select the Horizontal option, your screen looks 
similar to the one in Figure 7-6.

You might notice that Excel assigned the name NorthwindSales.xlsx:2 to the new 
 workbook window. In addition, it changed the name of the original workbook window to 
NorthwindSales.xlsx:1. NorthwindSales.xlsx:2 now becomes the active window, and as such, 
it’s  positioned on top.
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Figure 7-6 After clicking the New Window button to open a second window for the same 
workbook, select an Arrange option to fit both windows on the screen simultaneously.

Note
Again, if other workbooks are open, but you want to view only the windows of the 
active workbook, select the Windows Of Active Workbook check box in the Arrange 
Windows dialog box .

You can view any part of the workbook in any window associated with that workbook. In 
Figure 7-6, NorthwindSales.xlsx:2 originally displayed the summary worksheet when we 
first created it, because that was the active worksheet when we clicked the New Window 
button. Then we clicked the Brass tab in the new window, leaving the summary worksheet 
visible in NorthwindSales.xlsx:1.

Useful inconsistencies of new windows
When you create multiple windows of the same workbook, anything you do in one window 
happens in all windows—almost. New entries; formatting changes; inserting or deleting 
rows, columns, or worksheets; and just about any other editing changes are reflected in the 
windows. Display characteristics—or views—are not. This means that you can zoom in or 
out and change anything in the Workbook Views and Zoom groups on the View tab as well 
as use the Split and Freeze Panes commands. View adjustments affect only the active win-
dow. You can also click the File tab, click Options, select the Advanced category, and then 
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change the settings in the two Display Options sections: Display Options For This Workbook 
and Display Options For This Worksheet. You can apply these options differently to win-
dows of the same workbook. Just select the name of the window you want to change in the 
drop-down list, as shown in Figure 7-7.

Figure 7-7 You can change the display characteristics of one window without affecting the other.

Figure 7-8 shows a somewhat exaggerated example of worksheet auditing. Formulas are 
displayed in NorthwindSales.xlsx:1; the worksheet is zoomed in, the ribbon is collapsed; and 
the formula bar, row and column headings, and gridlines are removed—all in an effort to 
review the formulas in the summary worksheet to make sure they refer to the proper cells. 
You can use this technique to audit your worksheets.

If you create a view like NorthwindSales.xlsx:1 in Figure 7-8 and want to be able to re-
create it in the future, click the Custom Views button in the Workbook Views group on 
the View tab to save it. If you want to be able to re-create the entire workspace, including 
additional windows and their view settings, click the Save Workspace button in the Window 
group on the View tab.



Ch
ap

te
r 7

 Opening multiple windows for the same workbook 181

Figure 7-8 You can radically change view options in one window while maintaining a regular 
view of the same worksheet in another window.

For more information about custom views, see “Using custom views” in Chapter 6, “How to 
work a worksheet .” For more information about the auditing features in Excel, see “Auditing 
and documenting worksheets” in Chapter 8, “Worksheet editing techniques .” For more infor-
mation about formulas, see Chapter 12, “Building formulas .”

INSIDE OUT   Close the default settings window last

When you have two windows open in the same workbook and then close one of them, 
the “number” of the open window isn’t important, but the view settings are . In the 
example shown in Figure 7-8, if you finish your work and close NorthwindSales.xlsx:2, 
the modified view settings in NorthwindSales.xlsx:1 become the active view for the 
workbook. If you then save the workbook, you also save the modified view settings. 
Be sure you close the windows with view settings you don’t want to keep before you 
close the one with the settings you want to use as the default—don’t worry about the 
window number .
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Hiding and protecting workbooks
Sometimes you might want to keep certain information out of sight or protect it from 
inadvertent modification. You can conceal and protect your data by hiding windows, work-
books, or individual worksheets from view.

For information about protecting individual cells, see “Protecting worksheets” in Chapter 6 .

Hiding workbooks
At times, you might need to keep a workbook open so that you can access the information 
it contains, but you don’t want it to be visible, either for convenience or for security. When 
several open workbooks clutter your workspace, you can click the Hide button on the View 
tab to conceal some of them. Excel can still work with the information in the hidden work-
books, but they don’t take up space on your screen, and their file names don’t appear in 
the Switch Windows menu on the View tab.

To hide a workbook, activate it and then click View, Hide. Excel removes the workbook from 
view, but the workbook remains open and available in the workspace. To bring the hidden 
workbook into view, click View, Unhide, and then select the name of the hidden workbook. 

The Unhide command is available only when you have a workbook hidden. The Unhide 
dialog box, shown in Figure 7-9, lists all the hidden workbooks.

Figure 7-9 The Unhide dialog box lists all the workbooks you currently have hidden.
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Clicking the Hide button conceals any open window. However, if you have multiple win-
dows open for the same workbook, clicking the Hide button hides only the active window. 
The entire workbook isn’t hidden. For more information, see “Opening multiple windows 
for the same workbook” earlier in this chapter.

TROUBLESHOOTING
Nothing happens when I try to open a workbook
If, when you try to open a workbook, you don’t see any error messages or dialog boxes 
but the workbook doesn’t appear to open, the window was probably hidden when the 
workbook was last saved . The workbook is actually open; you just can’t see it .

If, in a previous Excel session, you clicked the Hide button on the View tab and then 
forgot about the hidden window when you exited Excel, you probably saw a message 
like “Do you want to save changes you made to Book1?” This refers to the hidden 
file—the change you made was the act of hiding it. The next time you open the file, it 
appears that nothing has happened, but if you look at the View tab, the Unhide button 
is active, which happens only when a hidden window is open in the workspace . Click 
the Unhide button, select the file name to make it visible once again, and then save it 
before exiting Excel .

Protecting workbooks
Protecting a workbook not only prevents changes to the complement of worksheets con-
tained in the workbook, but it can also prevent modifications to the way the workbook 
windows are displayed. To protect a workbook, click the Review tab, and click Protect Work-
book to display the dialog box shown in Figure 7-10.

Figure 7-10 Clicking Review, Protect Workbook helps insulate your workbooks from inadvertent 
modification.
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Selecting the Structure check box prevents any changes to the position, the name, and the 
hidden or unhidden status of the worksheets in the active workbook. When you select the 
Windows option, the workbook’s windows cannot be closed, hidden, unhidden, resized, or 
moved—in fact, the Minimize, Maximize, and Close buttons disappear. This does not mean 
you cannot close the workbook; you can still click the File tab and then click Close. How-
ever, if you have more than one window open for the workbook, you cannot close any of 
them individually.

These settings take effect immediately. This command is a toggle—you can turn protection 
off by clicking Protect Workbook again. If protection has been activated, the Protect Work-
book command button is highlighted, or “depressed.” If you specify a password in the Pro-
tect Structure And Windows dialog box, Excel prompts you to supply that password before 
it turns off worksheet protection.

Encrypting workbooks
You can provide another level of security for your workbooks by adding encryption. 
Encryption goes beyond simple password protection by digitally obscuring information to 
make it unreadable without the proper key to “decode” it. (Therefore, encrypted workbooks 
can be opened only by Excel.) You apply encryption by clicking the File tab, Info, Protect 
Workbook, Encrypt With Password. This displays a dialog box that prompts you for a pass-
word, as shown in Figure 7-11, and then redisplays itself to confirm the password.

Figure 7-11 Applying a password to encrypt a workbook also turns on protection of the 
workbook structure.

After encryption, you need the password to open the workbook again; the Protect Struc-
ture And Windows dialog box (shown in Figure 7-10) also uses this password to protect the 
workbook structure. Even if you turn off workbook protection, encryption is still active until 
you turn it off by clicking the Encrypt Document command again and removing the pass-
word from the Encrypt Document dialog box. 
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Saving workbooks or windows as hidden
Sometimes you might want to hide a particular workbook, perhaps even to prevent oth-
ers from opening and viewing its sensitive contents in your absence. If so, you can save the 
workbook as hidden. A hidden workbook is not visible when it’s opened. You can save a 
workbook as hidden by following these steps:

1. Close all open workbooks other than the one you want to hide, and then click View, 
Hide. 

2. Exit Excel.

3. When a message appears asking whether you want to save changes to the workbook, 
click Save.

The next time the workbook opens, its contents are hidden. To ensure that it cannot be 
unhidden by others, you might want to assign a password by clicking Review, Protect 
Workbook before hiding and saving the workbook.

Hiding worksheets
If you want to hide a particular worksheet in a workbook, click the Home tab, and in the 
Cells group, click Format. On the menu that appears, click Hide & Unhide, and then click 
Hide Sheet. When you do so, the active worksheet no longer appears in the workbook. To 
unhide a hidden worksheet, click Unhide Sheet on the same menu. This command becomes 
active after you have hidden a worksheet. The Unhide dialog box for worksheets is almost 
identical to the Unhide dialog box for workbooks shown in Figure 7-9. Select the worksheet 
you want to unhide, and then click OK.

Marking as final
When you need to share your finished workbooks with others rather than distribute them 
for collaboration, you might be interested in the Mark As Final command. Although anyone 
can still open a workbook that has been marked as final, the fact that you marked it as final 
helps your coworkers understand that it is a finished piece of work. Click the Info category 
on the File tab, and then click the Protect Workbook button to display the menu shown in 
Figure 7-12. 




