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CHAPTER 8

Worksheet editing techniques

Cut anD paSte. Insert and delete. Undo and redo. It all seems elementary, but as 
always in Microsoft Excel 2013, powerful features are hiding beneath the obvi-
ous approaches to the simplest tasks; in fact, after reading this chapter, you’ll find 

solutions to problems you probably never even considered. We’ll cover all the essential 
editing techniques, including editing multiple worksheets, checking spelling, selectively 
pasting entries, filling cells automatically, creating data series, and outlining and auditing 
worksheets.

Copying, cutting, and pasting
When you copy an item, Excel saves it in memory, using a temporary storage area called 
the Clipboard. You capture the contents as well as the formatting and any attached com-
ments or objects.

For more information about comments, see “Auditing and documenting worksheets” later in 
this chapter . For more information about objects, see Chapter 10, “Creating and formatting 
graphics .”

When you copy or cut cells, a marquee appears around the cell. (We used to refer to this 
scrolling dotted line as marching ants.) This marquee indicates the area you are copying or 
cutting. When you cut cells, the marquee disappears after you paste the cells. When you 
copy cells, the marquee persists after you paste the cells so that you can keep pasting these 
cells in other places.

The Cut, Copy, and Paste buttons in the Clipboard group on the Home tab are just swell, 
but you should know the keyboard shortcuts for the quintessential editing commands 
listed in Table 8-1. You can click the equivalent buttons on the ribbon, but really, if you 
never learn another keyboard shortcut, learn these. They work in most Windows programs.
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TABLE 8-1 Essential keyboard shortcuts

Press To

Ctrl+C Copy
Ctrl+X Cut
Ctrl+V Paste
Ctrl+Z Undo
Ctrl+Y Redo

Copying and pasting
After you copy, you can paste more than once. As long as the marquee is visible, you can 
continue to paste the information from the copied cells. You can copy this information to 
other worksheets or workbooks without losing your copy area marquee. The marquee per-
sists until you press Esc or perform any other editing action. The area you select for copying 
must be a single rectangular block of cells. If you try to copy nonadjacent ranges, you get 
an error message.

Collecting multiple items on the Clipboard

Although you cannot copy nonadjacent selections, you can use the Collect And Copy fea-
ture to copy (or cut) up to 24 separate items and then paste them where you want them—
one at a time or all at once. You do this by displaying the Clipboard task pane shown in 
Figure 8-1 by clicking the dialog box launcher next to the word Clipboard on the Home tab 
on the ribbon.

Ordinarily when copying, you can work with only one item at a time. If you copy several 
items in a row, only the last item you copy is stored on the Clipboard. However, if you first 
display the Clipboard task pane and then copy or cut several items in succession, each item 
is stored in the task pane, as shown in Figure 8-1.

You can change the regular collect-and-copy behavior so that Excel collects items every 
time you copy or cut regardless of whether the Clipboard task pane is present. To do so, 
click the Options button at the bottom of the Clipboard task pane (shown in Figure 8-1), 
and click Collect Without Showing Office Clipboard or Show Office Clipboard Automati-
cally, depending on whether you want the task pane to appear. The latter option activates 
an additional option, Show Office Clipboard When Ctrl+C Pressed Twice, which is one of 
the “automatic” methods.
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Previewing before you paste
You use the paste preview feature to see what a particular paste option looks like 
before you commit to actually pasting . After you copy or cut a cell or range, select 
the destination cell where you want to paste . Click the Paste menu on the Home tab 
(or right-click and use the Paste Options buttons on the shortcut menu) . When you 
position the pointer over each button, the result of that option is displayed on the 
worksheet in the specified location. In the following figure, we copied cells A1:A4, 
right-clicked cell C2 to display the shortcut menu, and then positioned the pointer over 
the Paste Options buttons:

The Paste menu on the Home tab is usually far enough out of the way that it won’t 
obscure the area of the sheet you’re working on . And because the shortcut menu 
appears where you right-click, you would think that it would always be in the way . But 
as you can see in the figure, it “ghosts” itself when you use the paste preview feature. 
For more about paste options in general, see “Pasting selectively using Paste Special” 
later in this chapter, and for information about the Transpose command in particular, 
see “Transposing entries” later in this chapter .

Each time you copy or cut an item, a short representation of the item appears in the Clip-
board task pane. Figure 8-1 shows four items in the Clipboard task pane. You can paste 
any or all of the items wherever you choose. To paste a single item from the Clipboard task 
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pane, first select the location where you want the item to go, and then click the item in the 
task pane. To empty the Clipboard task pane for a new collection, click the Clear All button.

Figure 8-1 The Clipboard task pane stores multiple items that you copy or cut.

Hunting and gathering
You can use the Clipboard task pane to quickly assemble a list . Although the Collect 
And Copy feature is useful for editing, it can also be a great tool for gathering infor-
mation . Copy items such as names or addresses from various locations in the order 
you want them to appear . Then click the Paste All button in the Clipboard task pane to 
paste all the items you have collected, in the order collected, into a single column .

Pasting multiples

After you copy, press Ctrl+V to paste whatever you copied. It’s a no-brainer. However, did 
you know that if you select a range of cells before pasting, Excel fills every cell in that range 
when you paste? Figure 8-2 illustrates this.
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Figure 8-2 Before you paste, select more cells than you copied to create multiple copies of your 
information.

In Figure 8-2, we did the following:

 ● Copied cell A1, selected the range C1:C12, and then pasted, resulting in Excel repeat-
ing the copied cell in each cell in the selected range.

 ● Copied Cells A1:A4, selected the range E1:E12, and then pasted, resulting in Excel 
repeating the copied range within the range.

 ● Copied cells A1:A4, selected cell G1, and then pasted, resulting in an exact duplicate 
of the copied range.

 ● Copied cells A1:A4, selected the range A15:G15, and then pasted, resulting in Excel 
repeating the copied range in each selected column.
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Note
If you select a paste range that contains more cells than the copied range, Excel repeats 
the copied cells until it fills the destination. However, if you select a paste range that is 
smaller than the copied range, Excel pastes the entire copied range anyway .

Using the Paste Options button

Notice in Figure 8-2 that we clicked the floating Paste Options button that appears near 
the lower-left corner of the pasted range. This button appears whenever and wherever you 
paste, offering actions applicable after pasting—a sort of “Smart Paste Special.” (Similar 
floating buttons offering context-triggered options appear after performing actions other 
than pasting, too.) The best part is that you can try each action in turn. Keep selecting paste 
options until you like what you see, and then press Enter. The following describes the most 
interesting items on the Paste Options menu:

 ● Formulas Pastes all cell contents, including formulas, but no formatting.

 ● Formulas And Number Formatting Pastes all cell contents, including formulas 
and number formats, but no text formats.

 ● No Borders Pastes everything but borders.

 ● Transpose Flips a column of data into a row and vice versa.

 ● Values Pastes cell contents and the visible results of formulas (not the formulas 
themselves) without formatting.

 ● Values And Number Formatting Pastes cell contents and the visible results of for-
mulas (not the formulas themselves); retains number formats, but not text formats.

 ● Values And Source Formatting Pastes cell contents and the visible results of for-
mulas (not the formulas themselves), plus all the copied or cut formats.

 ● Keep Source Column Widths Retains column widths. This option is like normal 
pasting with the added action of “pasting” the column width.

 ● Formatting Leaves the contents of the destination cells alone, and transfers the 
formatting. This works in the same way as the Format Painter button, located in the 
Clipboard group on the Home tab.

 ● Paste Link Instead of pasting the contents of the cut or copied cells, pastes a refer-
ence to the source cells, ignoring the source formatting.
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 ● Picture Pastes an image of the selected cells as a static graphic object.

 ● Linked Picture Pastes an image of the selected cells as a dynamic graphic object. If 
you make any changes to the original cells, the changes are reflected in the graphic 
object. This is handy for monitoring remote cells.

Cutting and pasting
When you cut rather than copy cells, subsequent pasting places one copy in the selected 
destination, removes the copied cells from the Clipboard, removes the copied data from its 
original location, and removes the marquee. When you perform a cut-and-paste operation, 
the following rules apply:

 ● Excel clears both the contents and the formats from the cut range and transfers them 
to the cells in the paste range. Excel adjusts any formulas outside the cut area that 
refer to the cells that were moved.

 ● The area you select for cutting must be a single rectangular block of cells. If you try 
to select nonadjacent ranges, you get an error message.

 ● Regardless of the size of the range you select before pasting, Excel pastes only the 
exact size and shape of the cut area. The upper-left corner of the selected paste area 
becomes the upper-left corner of the moved cells.

 ● Excel overwrites the contents and formats of any existing cells in the range where 
you paste. If you don’t want to lose existing cell entries, be sure your worksheet has 
enough blank cells below and to the right of the cell you select as the upper-left cor-
ner of the paste area to hold the entire cut area.

 ● You cannot use Paste Special after cutting. Furthermore, no “floating button” menus 
appear when you paste after cutting.

Pasting selectively using Paste Special

Paste Special is quite possibly the most useful (and most used) power-editing feature. You 
can use this feature in many ways, but probably the most popular way is copying the value 
in a cell without copying the formatting or the underlying formula. After you copy a cell 
or cells, click the Paste menu on the Home tab, and click Paste Special to display the Paste 
Special dialog box, shown in Figure 8-3. (You must copy to use Paste Special. When you cut, 
Paste Special is unavailable.) The most popular Paste Special actions are directly accessible 
as commands on the Paste menu on the Home tab, as shown on the left in Figure 8-3.
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Note
The Paste menu is actually a button with a downward-pointing arrow below it; clicking 
the button is equivalent to clicking the Paste command . To display the menu shown on 
the left in Figure 8-3, click the arrow .

Figure 8-3 Paste Special is probably the most popular power-editing feature, and its most often 
used options are available as commands on the Paste menu.

Note
You can also open the Paste Special dialog box by right-clicking the cell where you 
want to paste and then clicking Paste Special .

Here’s what the Paste Special options do:

 ● All Predictably, pastes all aspects of the selected cell, which is the same as clicking 
the Paste command.

 ● Formulas Transfers only the formulas from the cells in the copy range to the cells in 
the paste range, adjusting relative references. This option is also available as a com-
mand on the Paste menu.
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 ● Values Pastes static text, numeric values, or only the displayed values resulting from 
formulas. This option is also available as the Paste Values command on the Paste 
menu.

 ● Formats Transfers only the formats in the copy range to the paste range.

Note
You can quickly copy and paste formats from a single cell or from a range of cells 
by using the Format Painter button, next to the Paste menu on the Home tab .

 ● Comments Transfers only comments attached to selected cells.

 ● Validation Pastes only the data validation settings you have applied to the selected 
cells.

 ● All Using Source Theme Transfers the copied data, and applies the theme from 
the copied cells.

 ● All Except Borders Transfers data without disturbing the border formats you spent 
so much time applying. This option is also available as the No Borders command on 
the Paste menu.

 ● Column Widths Transfers only column widths, which is handy when trying to make 
a worksheet look consistent for presentation.

 ● Formulas And Number Formats Transfers only formulas and number formats, 
which is helpful when you are copying formulas to previously formatted areas. Usu-
ally, you want the same number formats applied to formulas you copy, wherever they 
happen to go.

 ● Values And Number Formats Transfers only the resulting values (but not the for-
mulas) and number formats.

 ● All Merging Conditional Formats Transfers cell contents and formats, and merges 
any conditional formats in the copied cells with those found in the destination range. 
Copied conditions take precedence if there is a conflict.

For more information about themes, see “Using themes and cell styles” in Chapter 9, “Work-
sheet formatting techniques .” For more about conditional formatting, see “Formatting condi-
tionally” in Chapter 9 .

Because the All option pastes the formulas, values, formats, and cell comments from the 
copy range into the paste range, it has the same effect as clicking Paste, probably making 
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you wonder why Excel offers this option in the Paste Special dialog box. That brings us to 
our next topic—the Operation options.

Pasting using math operators

You use the options in the Operation area of the Paste Special dialog box to mathematically 
combine the contents of the copied cells with the contents of the cells in the paste area. 
When you select any option other than None, Excel does not overwrite the destination cell 
or range with the copied data. Instead, it uses the specified operator to combine the copy 
and paste ranges.

For example, say you want to get a quick list of combined monthly totals for the Northern 
and Eastern regions in Figure 8-4. First, copy the Northern Region figures to an empty area 
of the worksheet, and then copy the Eastern Region numbers; select the first cell in the col-
umn of values you just copied and click Paste Special. You then select the Values and Add 
options in the Paste Special dialog box, and after clicking OK, you get the result shown at 
the bottom of Figure 8-4.

Figure 8-4 We used the Values option in the Paste Special dialog box to add the totals from the 
Eastern Region to those of the Northern Region.
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You’ll find the MonthlyClaims.xlsx file with the other examples on the companion website.

The other options in the Operation area of the Paste Special dialog box combine the con-
tents of the copy and paste ranges using the appropriate operators. Just remember that 
the Subtract option subtracts the copy range from the paste range, and the Divide option 
divides the contents of the paste range by the contents of the copy range. Also note that 
if the copy range contains text entries and you use Paste Special with an Operation option 
(other than None), nothing happens.

Select the Values option when you use any Operation option. As long as the entries in the 
copy range are numbers, you can use All, but if the copy range contains formulas, you’ll get 
“interesting” results. As a rule, avoid using the Operation options if the paste range contains 
formulas.

Note
Excel assigns the value 0 to blank spaces in the copy and paste ranges, regardless of 
which Operation option you select .

Pasting links

The Paste Link button in the Paste Special dialog box, shown in Figure 8-4, is a handy way 
to create references to cells or ranges. Although the Paste Special dialog box offers more 
options, using the Paste Link command on the Paste menu on the Home tab is more con-
venient. When you click Paste Link, Excel enters an absolute reference to the copied cell in 
the new location. For example, if you copy cell A3, select cell B5, click the Paste menu, and 
then click Paste Link, Excel enters the formula =$A$3 in cell B5.

If you copy a range of cells, Paste Link enters a similar formula for each cell in the copied 
range to the same-sized range in the new location.

For more information about absolute references, see “Understanding relative, absolute, and 
mixed references” in Chapter 12, “Building formulas .”

Skipping blank cells

The Paste Special dialog box contains a Skip Blanks check box you can select when you 
want Excel to ignore any blank cells in the copy range. If your copy range contains blank 
cells, Excel usually pastes them over the corresponding cells in the paste area. As a result, 
empty cells in the copy range overwrite the contents, formats, and comments in corre-
sponding cells of the paste area. When you select Skip Blanks, however, the corresponding 
cells in the paste area are unaffected by the copied blanks.
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Transposing entries

One of the often-overlooked but extremely useful Paste Special features is Transpose, which 
helps you reorient the contents of the copied range when you paste—that is, data in rows is 
pasted into columns, and data in columns is pasted into rows. (This option is also available 
as a command on the Paste menu.) For example, in Figure 8-5, we copied the data shown 
in cells B3:E3, and then we selected cell J3 and clicked Transpose on the Paste menu on the 
Home tab. This works both ways. If we subsequently select the range just pasted and click 
Transpose again, the data is pasted in its original orientation.

Figure 8-5 We copied cells B3:E3, selected cell J3, and then clicked Home, Paste, Transpose to 
redistribute the row of labels into a column of labels.

INSIDE OUT   Using paste values with arrays

As with any other formula, you can convert the results of an array formula to a series 
of constant values by copying the entire array range and—without changing your 
selection—clicking the Home tab, Paste, Paste Values . When you do so, Excel overwrites 
the array formulas with their resulting constant values . Because the range now contains 
constant values rather than formulas, Excel no longer treats the selection as an array . 
For more information about arrays, see “Using arrays” in Chapter 12 .
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Note
If you transpose cells containing formulas, Excel transposes the formulas and adjusts 
cell references . If you want the transposed formulas to continue to correctly refer to 
nontransposed cells, be sure that the references in the formulas are absolute before 
you copy them . For more information about absolute cell references, see “Using cell 
references in formulas” in Chapter 12 .

Pasting hyperlinks
The Hyperlink command on the Insert tab has a specific purpose: to paste a hyperlink that 
refers to the copied data in the location you specify. When you create a hyperlink, it’s as 
though Excel draws an invisible box, which acts like a button when you click it, and places it 
over the selected cell.

Hyperlinks in Excel are similar to web links that, when clicked, launch a webpage. You can 
add hyperlinks in your workbooks to locations on the web—a handy way to make related 
information readily available. You can use hyperlinks to perform similar tasks among your 
Excel worksheets, such as to provide an easy way to access other worksheets or workbooks 
that contain additional information. You can even create hyperlinks to other Microsoft 
Office documents, such as a report created in Microsoft Word or a Microsoft PowerPoint 
presentation.

Within Excel, you create a hyperlink by copying a named cell or range, navigating to the 
location where you want the hyperlink (on the same worksheet, on a different worksheet, 
or in a different workbook), and then clicking Insert, Hyperlink. To create a hyperlink in 
and among Excel worksheets and workbooks, you must first assign a name to the range to 
which you want to hyperlink. (The easiest method is to select the cell or range and type a 
name in the Name box at the left end of the formula bar.) Note that hyperlinks differ from 
Excel links, which are actually formulas.

For more information, see “Pasting links” earlier in this chapter. For information about defin-
ing names, see “Naming cells and cell ranges” in Chapter 12 . For more information about 
hyperlinks, see Chapter 31, “Linking, hyperlinking, and embedding .”

When you rest your pointer on a hyperlink, a ScreenTip appears showing you the name and 
location of the document to which the hyperlink is connected, as shown in Figure 8-6.
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Figure 8-6 We created hyperlinks to supporting workbooks at the bottom of this worksheet.

To use a hyperlink, just click it. To select the cell containing the hyperlink without activating 
the link, hold the mouse button down until the pointer changes to a cross and then release 
the mouse button. To edit or delete a hyperlink, right-click it and then click Edit Hyperlink 
or Remove Hyperlink.

The NorthwindSales.xlsx, NorthwindStaff.xlsx, and NorthwindStrategy.xlsx files are with the 
other examples on the companion website.

Moving and copying with the mouse
Sometimes referred to as direct cell manipulation, this feature lets you quickly drag a cell or 
range to a new location. It’s that simple. When you select a cell or range, move the pointer 
over the edge of the selection until the four-headed arrow pointer appears, and then click 
the border and drag the selection to wherever you like. As you drag, an outline of the 
selected range appears, which you can use to help position the range correctly.

To copy a selection rather than move it, hold down the Ctrl key while dragging. The pointer 
then appears with a small plus sign next to it, as shown in Figure 8-7, which indicates you 
are copying rather than moving the selection.
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Note
If direct cell manipulation doesn’t seem to be working, click the File tab, click Options, 
and in the Advanced category under Editing Options, check that the Enable Fill Handle 
And Cell Drag-And-Drop option is selected .

Figure 8-7 Before you finish dragging, press Ctrl to copy the selection. A plus sign and 
destination reference appear next to the pointer.

You can also use direct cell manipulation to insert copied or cut cells in a new location, 
moving existing cells out of the way in the process. For example, in the first image in Figure 
8-8, we selected cells A6:E6 and then dragged the selection while holding down the Shift 
key. A gray I-beam indicates where Excel will insert the selected cells when you release the 
mouse button. The I-beam appears whenever the pointer rests on a horizontal or vertical 
cell border. In this case, the I-beam indicates the horizontal border between rows 8 and 
9, but we could just as easily insert the cells vertically (which would produce unwanted 
results). You’ll see the I-beam insertion point flip between horizontal and vertical as you 
move the pointer around the worksheet. To insert the cells, release the mouse button while 
still pressing the Shift key. When you release the mouse button, the selected cells move to 
the new location, as shown in the second image in Figure 8-8.

For information about using the keyboard for this task, see “Inserting copied or cut cells” 
later in this chapter .

If you press Ctrl+Shift while dragging, the selected cells are both copied and inserted 
instead of moved. Again, a small plus sign appears next to the pointer, and Excel inserts 
a copy of the selected cells in the new location, leaving the original selected cells intact. 
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You can also use these techniques to select entire columns or rows and then move or copy 
them to new locations.

Figure 8-8 The gray I-beam indicates where Excel will insert selected cells.

Inserting and deleting
In the realm of spreadsheets, the complementary actions of inserting and deleting are 
collectively the second most-used editing techniques. Inserting and deleting rows and col-
umns of information have some nuances that don’t exist in the world of word processing, 
for example, but that you must consider.

Inserting columns and rows
On the Home tab, you can click commands on the Insert menu in the Cells group to add 
cells, columns, and rows to a worksheet—and even add a new sheet to a workbook. How-
ever, when you need to insert entire rows or columns, it’s easiest to right-click a column or 
row heading, which simultaneously selects the whole row or column and displays the short-
cut menu shown in Figure 8-9. (You can also drag through several rows or columns and 
then right-click the selection to insert the same number of columns or rows you selected.) 
Then just click Insert.

After inserting the column in Figure 8-9, the contents of column D move to column E, leav-
ing the freshly inserted column D blank and ready for new information. The newly inserted 
cells take on the same formats as the cells in the column to the left, and Excel adjusts the 
formulas in cells F4:F15 to account for the expanded range.

A floating Insert Options button appears after you insert, which you can use to change the 
formatting of the inserted cells. Click the button to display the menu shown in the second 
image in Figure 8-9. If you want to extend a table by inserting a column on its right, for 
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example, you might want to use the Format Same As Right or Clear Formatting option. The 
default Format Same As Left option works for our example.

Figure 8-9 Right-click a row or column heading, and click Insert. Click the Insert Options button 
that appears after you insert for some post-insertion options.

Note
When you insert a row instead of a column, the commands on the Insert Options menu 
are Format Same As Above (the default), Format Same As Below, and Clear Formatting .
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Handy keyboard shortcuts
Some of us are mouse fans; others are keyboard jockeys . If you’re a good typist, you 
might prefer keeping your hands on the keys as much as possible . If so, this table of 
keyboard shortcuts for typical insertion actions is for you . Note that commas denote 
sequential keystrokes and plus signs denote additive keystrokes . For example, you press 
Alt, let go, then press I, let go, then press R to insert a row . But you hold down Shift 
and press Spacebar to select a row . 

Press To

Alt, I, R Insert rows
Alt, I, C Insert columns
Alt, E, D Delete selected rows or columns
Ctrl+Spacebar Select columns
Shift+Spacebar Select rows

Inserting cells
You can insert cells or cell ranges rather than entire rows or columns by using the shortcut 
menu technique described earlier or by clicking Home, Insert, Insert Cells, which displays 
the Insert dialog box shown in Figure 8-10.

Figure 8-10 Click the Insert Cells command to choose the direction in which to move existing 
cells in your worksheet.

Note
The Insert menu is actually a button with an arrow to its right; if you click the button, it 
is the equivalent of clicking the Insert Cells command, which moves cells either down 
or to the right, depending on the shape of the selected cell range . To display the menu 
shown on the left in Figure 8-10, click the arrow .



Ch
ap

te
r 8

 Inserting and deleting 209

Note
You can insert multiple nonadjacent cells when you use the Insert command, but only 
when inserting blank cells . Inserting nonadjacent cut or copied cells is not allowed .

Inserting copied or cut cells

Often, you need to copy or move existing data to the middle of another area of existing 
data, moving other data out of the way in the process. You can do this the hard way by 
inserting just the right amount of space in the destination area and then copying or cutting 
cells and pasting them to the new location. However, it’s much easier to click Home, Insert, 
Insert Copied Cells or Insert Cut Cells because this handles all these actions for you. These 
commands appear on the Insert menu (or on the shortcut menu) only when you copy or 
cut some cells. Sometimes it’s obvious what needs to happen. For example, if you cut an 
entire row, you’ll surely want to insert the entire row somewhere else. In these cases, Excel 
employs some common-sense rules and executes the action without hesitation. If Excel 
needs more information about how to adjust the worksheet, it opens the Insert Paste dia-
log box shown in Figure 8-11.

Figure 8-11 When you insert after copying or cutting cells, the Insert Paste dialog box appears.

For example, you can use cutting and inserting to add rows for more data in Figure 8-11 by 
copying the rows containing 2013 data and editing the contents, thereby saving yourself 
some unnecessary typing. To do so, select cells A6:F9 and press Ctrl+C to copy the range. 
Then click Home, Insert, Insert Copied Cells to display the Insert Paste dialog box. Then 
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select the Shift Cells Down option, and click OK. Excel inserts the copied data and moves 
the rest of the table down to accommodate the insertion, as shown in Figure 8-12.

Figure 8-12 Inserting previously copied or cut cells is faster than inserting cells and then 
copying or cutting data to fill the inserted range.

Deleting cells, columns, and rows
You can use the Delete menu on the Home tab (located in the Cells group) to remove cells, 
rows, or columns from your worksheet. Deleting removes the selected cell or range from 
the worksheet, shifting cells to fill the empty space you create.

Note
The Delete menu is actually a button with an arrow to its right; if you click the button, 
it is the equivalent of clicking the Delete Cells command, which moves remaining cells 
either up or to the left, depending on the shape of the selected cell range . To display 
the menu, click the arrow .
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Here are some guidelines for using Delete:

 ● You can delete multiple nonadjacent rows by pressing Ctrl and clicking each non-
adjacent row before clicking Delete. Excel shifts everything below the deleted rows 
upward and adjusts any formulas accordingly.

 ● You can delete entire columns by selecting the column heading before clicking the 
Home tab and then, in the Cells group, the Delete command. Excel moves everything 
to the right of the deleted columns left and adjusts any formulas accordingly.

 ● You can delete multiple nonadjacent selections in one operation as long as you 
delete either entire rows or entire columns. You cannot delete entire rows and col-
umns at the same time, however, because they overlap. The universe would implode.

 ● You can delete partial rows and columns by selecting a cell or cells and clicking 
Delete. Excel displays the Delete dialog box shown in Figure 8-13. You can choose the 
direction you want to shift remaining cells to fill the gap, or you can choose to elimi-
nate the entire rows or columns inhabited by the selected cells.

Figure 8-13 Use the Delete dialog box to choose the direction to move cells.

For more information about formulas and cell references, see Chapter 12 .
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When you delete (or insert) partial rows or columns, it’s easy to misalign data. For example, 
in Figure 8-14 we deleted cells A6:E9 with the default Shift Cells Up option selected. This 
eliminated the cells referred to by the formulas in column F, producing #REF errors. In addi-
tion, the column F totals in rows 13 through 20 now refer to the data in rows 9 through 16. 
This is a case where we should have cleared the cell contents rather than deleted the cells.

CAUTION!
Although you can generally use Undo to cancel a deletion, you should take heed of 
these important points . Before you delete an entire column or row, scroll through your 
worksheet to be sure you’re not erasing important information that is not currently 
visible . Deleting cells that are referred to by formulas can be disastrous, as Figure 8-14 
illustrates . Finally, when you delete a column or row referred to by an argument of a 
function, Excel modifies the argument, if possible, to account for the deletion. This 
adaptability is a compelling reason to use functions wherever possible . For more about 
using functions, see Chapter 13, “Using functions .”

Figure 8-14 You can create errors when you delete the wrong cells.
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Fixing formula problems
In the following worksheet, notice that the formulas in row 16 have small triangular 
indicators in the upper-left corner of each cell (they are green on your screen):

These triangles indicate an anomaly of some kind; in this case, we moved cells around 
within the table, so the formulas no longer include the cells we moved . Notice in the 
graphic that the formula bar displays the formula =SUM(B4:B47), omitting cells B8:B15 . 
We used the Insert Cut Cells technique described in this chapter to move the rows con-
taining January through August data from the top of the table to the bottom, which 
created the problem . When you insert or move rows or columns at the edge of cell 
ranges referred to by formulas, the formulas might not be able to adjust properly, as is 
the case here. Excel offers help. As shown here, not only do the little flags appear, but 
when you select one of the formula cells, a menu appears offering a Formula Omits 
Adjacent Cells item containing pertinent options .

The Update Formula To Include Cells option works correctly in our example . This is a 
much easier solution than editing each formula manually .
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Clearing cells
The difference between deleting and clearing isn’t subtle. Although deleting completely 
removes selected cells, shifting adjacent cells to fill the void, clearing leaves selected cells 
in place and removes contents, formats, and any comments that might be attached. The 
Home tab includes a Clear menu, which is one of the buttons in the Editing group. Excel 
hides the “Clear” label if the window is too narrow, but you can always recognize the but-
ton by its eraser icon. Figure 8-15 shows the Clear menu.

Figure 8-15 The commands on the Clear menu remove the corresponding attributes of selected 
cells without removing the cells.

The commands on the Clear menu perform the following tasks on selected cells:

 ● Clear All removes all text, numbers, formulas, formats, borders, and any attached 
comments.

 ● Clear Formats removes only formatting and borders.

 ● Clear Contents removes only text, numbers, and formulas.

 ● Clear Comments removes only the attached comments.

 ● Clear Hyperlinks removes only hyperlinks, leaving the formatting intact.

 ● Remove Hyperlinks removes hyperlinks and formatting.

Inserting, deleting, and clearing cells with the mouse
To perform the next group of operations, you use the fill handle, a tiny black square that 
appears in the lower-right corner of the selection rectangle, which is the bold border that 
appears around the selected cell or range. If you select entire rows or columns, the fill han-
dle appears next to the row or column heading.
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When you select a single cell and drag the fill handle in any direction, Excel copies the con-
tents of that cell to all the cells through which you drag (with exceptions, which you’ll learn 
later). When you select more than one cell, Excel either copies the range or extends a data 
series in the direction you drag, depending on the cell contents, the shape of the selec-
tion, and whether you are holding down Ctrl. Pressing the Shift key while dragging the fill 
handle lets you insert blank cells into a worksheet.

In the worksheet at the top in Figure 8-16, we selected A7:G7 and dragged the fill handle 
one row down while pressing the Shift key. The pointer became a double-headed arrow. 
The worksheet on the bottom in Figure 8-16 shows the newly inserted blank cells.

You use the same technique to insert entire blank rows or columns—just select the row 
or column headings, or press Shift and drag the fill handle, which appears adjacent to the 
row or column headings. You can just as easily delete cells, columns, or rows using a similar 
technique. To delete the cells we inserted in Figure 8-16, select A8:G8, hold down Shift, 
and then drag the fill handle up one row. The area turns gray, and the pointer changes to a 
similar double-headed arrow, with the arrows pointing inward this time. When you release 
the mouse button, Excel deletes the selection.

Figure 8-16 Drag the fill handle while pressing Shift to insert cells.

If you drag the fill handle back over selected cells without pressing Shift, you clear the cell 
contents instead of deleting the cells. This clears formulas, text, and numbers only. If you 
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hold down the Ctrl key while dragging over a selection, you clear all the cell contents as 
well as the formatting, borders, and comments.

Fill handles and cell selection rectangles
The cell selection rectangle is the heavy black-bordered box that surrounds the cur-
rently selected cells . There is only one fill handle in a cell selection rectangle, regardless 
of the number of cells:

Fill handle            Fill handle drag pointer          Selection drag pointer

Dragging the fill handle extends the selection and performs other feats of prowess, as 
described in this chapter . Dragging the selection rectangle moves or copies the selec-
tion, also as described in this chapter. If the fill handle is not visible, click the File tab, 
click Options, and then click the Advanced category . In the Editing Options area, select 
the Enable Fill Handle And Cell Drag-And-Drop check box . The Alert Before Overwrit-
ing Cells check box is automatically selected (and recommended) .

Dragging with the right mouse button
If you select cells and then drag the selection rectangle using the right mouse button, a 
shortcut menu appears when you release the button, as shown in Figure 8-17. You can use 
the options on the shortcut menu to consummate your edit in a variety of ways.

Figure 8-17 Drag the selection with the right mouse button to display a shortcut menu.
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The options on the shortcut menu are as follows:

 ● Move Here Moves the source cells to the selected destination

 ● Copy Here Copies the source cells to the selected destination

 ● Copy Here As Values Only Copies the visible values from the source cells to the 
selected destination cells but does not copy formulas

 ● Copy Here As Formats Only Copies the formats of the source cells to the destina-
tion cells without affecting the contents

 ● Link Here Creates linking formulas at the destination that refer to the source cells

 ● Create Hyperlink Here Creates a web-style link to the source cells in the selected 
destination

 ● The Shift options Lets you copy or move the source cells to a location that con-
tains existing data, shifting it out of the way in the selected direction

Undoing previous actions
The word undo was never widely used until people started using computers; now it’s a verb 
that we all wish we could apply to more things in life. In Excel, you can click the Undo but-
ton, located on the Quick Access Toolbar, or press Ctrl+Z to recover from mistakes.

The Undo button includes a drop-down list of up to the last 100 actions you performed. 
You can then select and simultaneously undo any number of these actions at once. You 
display the drop-down list by clicking the small downward-pointing arrow next to the Undo 
button, as shown in Figure 8-18.

Figure 8-18 Click the arrow next to the Undo button to select and simultaneously undo up to 
the last 100 actions.
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With the drop-down list visible, move your pointer down the list, and select the number of 
actions you want to undo. When you click, your worksheet reverts to the condition it was in 
before the selected actions.

Undo reverses the effect of most editing actions and restores any entry in the formula bar. 
For example, if you accidentally delete a range of data, use Undo to replace the entries. If 
you edit the contents of a cell and subsequently discover that your changes are incorrect, 
use Undo to restore the original cell entry. In addition, you can use Undo to reverse format-
ting and many other types of actions.

Unfortunately, Excel has many actions that Undo can’t reverse, such as saving workbooks 
and deleting worksheets. Closing a workbook erases all the undoable actions displayed in 
the Undo list. Predictably, actions you cannot undo do not appear in the Undo drop-down 
list.

Redoing what you’ve undone
After you use Undo, you can then use Redo, which, unsurprisingly, reverses Undo. You can 
press Ctrl+Y to redo the last action or click the Redo button on the Quick Access Toolbar, 
which operates similarly to Undo. Redo also offers a drop-down list with all the undone 
editing actions. When you redo an action, Excel transfers it to the Undo drop-down list. 
Redo is valid only if Undo was your last action. After you have redone all the “undos” (up to 
100), you’re back to the “true” last action—that is, the last action you performed before you 
used Undo.

You can take advantage of Undo and Redo to see the effects of an editing change in your 
worksheet. If you edit a cell that is referred to in several formulas, you can use Undo and 
Redo to get a “before and after” look at the results displayed by the formulas.

Repeating your last action
To repeat the last editing action, press Ctrl+Y. (The Repeat button does not ordinarily 
appear on the Quick Access Toolbar, but you can add it. See “Customizing the Quick Access 
Toolbar” in Chapter 3, “Custom-tailoring the Excel workspace.”)

Redo and Repeat share the same keyboard shortcut because you can do only one or the 
other at any given moment. Being able to repeat the last action is a great timesaver and is 
particularly handy with repetitive chores.
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Unlike Undo, Repeat works with most actions. The only exceptions are those actions you 
can’t logically repeat. For example, if you save a file by clicking the File tab and then Save, 
you can’t repeat the action. Whatever the case, Repeat reflects the last repeatable action.

Editing cell contents
You can use the formula bar to edit the contents of a selected cell, or you can perform your 
editing “on location” in the cell. Excel also includes a few special features you can apply to 
tasks, such as entering date sequences, which once involved editing each cell but are now 
semiautomatic if you know where to find the “trigger.”

Editing in cells or in the formula bar
While typing or editing the contents of a cell, you can use Cut, Copy, Paste, and Clear 
to manipulate cell entries. Often, retyping a value or formula is easier, but using com-
mands is convenient when you’re working with long, complex formulas or with labels. 
When you’re working in a cell or in the formula bar, these commands work just as they 
do in a word-processing program such as Word. For example, you can copy all or part of 
a formula from one cell to another. For example, suppose cell A10 contains the formula 
=IF(NPV(.15,A1:A9)>0,A11,A12) and you want to type =NPV(.15,A1:A9) in cell B10.

Note
You can edit the contents of cells without using the formula bar . By double-clicking a 
cell, you can perform any formula bar editing procedure directly in the cell .

To do so, select cell A10, and in the formula bar, select the characters you want to copy—in 
this case, NPV(.15,A1:A9). Then press Ctrl+C, or click the Copy button (located in the Clip-
board group on the Home tab). Finally, select cell B10, type = to begin a formula, and press 
Ctrl+V (or click the Paste button).

Note
Excel does not adjust cell references when you cut, copy, and paste within a cell or in 
the formula bar . For information about adjustable references, see “How copying affects 
cell references” in Chapter 12 .

When you type or edit formulas containing references, Excel gives you visual aids called 
range finders to help you audit, as shown in Figure 8-19, where we obviously have a 
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problem with our SUM formula. The total should include all the rows of data, so drag a 
handle on a bottom corner of the range-selection rectangle until it includes all the correct 
cells.

Figure 8-19 Double-click a cell containing a formula to edit it and to display range finders.

For more information about formulas, see Chapter 12 . For more about auditing, see “Auditing 
and documenting worksheets” later in this chapter .

Note
You can disable in-cell editing if you want . To do so, click the File tab, click Options, 
and in the Advanced category, clear the Allow Editing Directly In Cells check box in the 
Editing Options area .

Editing options
The Advanced category in the Excel Options dialog box (which you access by clicking the 
File tab and then Options) contains an assortment of options that control editing-related 
workspace settings, as shown in Figure 8-20. These options include the following:

 ● After Pressing Enter, Move Selection This locks in the entry and makes the cell 
below active. To change the direction of the selection after you press Enter, use the 
Direction drop-down list. When you clear this check box, pressing Enter locks in the 
entry and leaves the same cell active.

 ● Automatically Insert A Decimal Point For those of us who remember using 
10-key calculators, this is equivalent to the “floating point” setting. Ordinarily, you 
type numbers and decimal points manually. To have Excel enter decimal points for 
you, select this option, and then select the number of decimal places you want. 
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For example, when you type 12345 with two decimal places specified, Excel enters 
123.45 in the cell. When you apply this option, Fixed Decimal appears in the status 
bar. This option applies only to entries you make after you select it, without altering 
existing data. It also applies only when you do not type a decimal point. If you type a 
number including a decimal point, the option has no effect.

Figure 8-20 Click the File tab, Options, Advanced to display editing-related workspace 
settings.

 ● Enable Fill Handle And Cell Drag-And-Drop This is required for the direct manip-
ulation of cells using the mouse. See “Moving and copying with the mouse” earlier 
in this chapter. Leaving the Alert Before Overwriting Cells option selected is always a 
good idea.

 ● Allow Editing Directly In Cells This is required for in-cell editing. See “Editing in 
cells or in the formula bar” earlier in this chapter.

 ● Extend Data Range Formats And Formulas This lets Excel apply formatting from 
existing cells to new cells entered in a list or table.

 ● Enable Automatic Percent Entry This helps you type values in cells with the Per-
centage format. When you select this check box, all entries less than 1 are multiplied 
by 100. When you clear this check box, all entries—including those greater than 
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1—are multiplied by 100. For example, in a cell to which you already applied the Per-
centage format, typing either .9 or 90 produces the same result—90%—in the cell. If 
you clear the Enable Automatic Percent Entry check box, typing 90 results in the dis-
played value 9000% (as long as you applied the Percentage format to the cell).

Note
A quick way to apply the Percentage format to a clean cell is to type a number 
as a percentage . For example, type 1% in a cell, and the cell then displays subse-
quent numbers in the same Percentage format .

 ● Enable AutoComplete For Cell Values This lets Excel suggest cell entries by com-
paring existing values it finds in the same column as you type. See “Letting Excel help 
with typing chores” later in this chapter.

 ● Automatically Flash Fill This lets Excel suggest cell entries by comparing existing 
values it finds in adjacent columns as you type. See “Automatic parsing and concat-
enation using Flash Fill” later in this chapter.

 ● Zoom On Roll With IntelliMouse Ordinarily, if your mouse has a wheel, rotating it 
causes the worksheet to scroll (or zoom while pressing Ctrl). Select this check box to 
switch the behavior of the wheel so that the worksheet zooms when you rotate the 
wheel (or scrolls while you press Ctrl).

 ● Alert The User When A Potentially Time-Consuming Operation Occurs If an 
editing operation will affect a large number of cells, this option controls whether 
you are notified and lets you specify the number of cells it takes to trigger the 
notification.

 ● Use System Separators Ordinarily Excel defaults to the designated numeric sepa-
rators for decimals and thousands (periods and commas, respectively) specified by 
your Windows system settings. If you want to specify alternative separators, you can 
do so here.

 ● Show Paste Options Button/Show Insert Options Buttons This activates the 
floating button menus that appear after pasting or inserting. Ordinarily, after you 
perform a paste or an insert operation, a floating button appears, offering a menu of 
various context-specific actions you can then perform. Clear these options to turn off 
these features.
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 ● Cut, Copy, And Sort Inserted Objects With Their Parent Cells This is required to 
“attach” graphic objects to cells. See “Tools to help you position objects on the work-
sheet” in Chapter 10.

Understanding fixed and floating decimals
The Automatically Insert A Decimal Point option in the Advanced category of the Excel 
Options dialog box is handy when you need to type long lists of numeric values . (It’s 
equivalent to the floating-decimal feature available on most 10-key calculators.) For 
example, if you’re performing a lengthy data-entry task such as typing multiple dol-
lar values on a worksheet, select the Automatically Insert A Decimal Point option, and 
click 2 in the Places list . Then just type numbers and press Enter, which saves you an 
extra keystroke for the decimal point in each entry . If you’re entering 1,000 values, typ-
ing 295 instead of 2 .95 eliminates 25 percent of the keystrokes you would otherwise 
have to perform . However, you need to be careful to either type trailing zeros or add 
decimal points to some numbers . For example, you usually type 5 to enter a 5 .00 value, 
but with two fixed decimal places turned on, the same entry becomes 0.05, making it 
necessary for you to type either 500 or 5. to correctly place the decimal point .

Filling cells and creating data series
As described earlier in this chapter, the fill handle has many talents to make it simple to 
enter data in worksheets. Uses of the fill handle include quickly and easily filling cells and 
creating data series by using the incredibly useful Auto Fill feature.

Take a look at Figure 8-21. If you select cell B2 and drag the fill handle down to cell B5, 
Excel copies the contents of cell B2 to cells B3 through B5. However, if you click the floating 
Auto Fill Options button that appears, right after you drag, you can select a different Auto 
Fill action, as shown in Figure 8-22 for the range C2:C5.

Figure 8-21 Copy the contents of a cell to adjacent cells by dragging the fill handle.
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Figure 8-22 Create a simple series by dragging the fill handle and then clicking Fill Series on the 
Auto Fill Options menu.

INSIDE OUT   Create decreasing series

Generally, when you create a series, you drag the fill handle down or to the right, and 
the values increase accordingly . You can also create a series of decreasing values by 
dragging the fill handle up or to the left. Select the starting values in cells at the bot-
tom or to the right of the range you want to fill, and then drag the fill handle back 
toward the beginning of the range .

If you click Fill Series on the Auto Fill Options menu, Excel creates the simple series 21, 22, 
and 23 instead of copying the contents of cell C2. If, instead of selecting a single cell, you 
select the range C1:C2 in Figure 8-22 and drag the fill handle down to cell C5, you create a 
series that is based on the interval between the two selected values, resulting in the series 
30, 40, and 50 in cells C3:C5. If you click Copy Cells on the Auto Fill Options menu, Excel 
copies the cells instead of extending the series, repeating the pattern of selected cells as 
necessary to fill the range. Instead of filling C3:C5 with the values 30, 40, and 50, choosing 
Copy Cells will enter the values 10, 20, and 10 in C3:C5.

If you select a text value and drag the fill handle, Excel copies the text to the cells where 
you drag. If, however, the selection contains both text and numeric values, the Auto Fill 
feature takes over and extends the numeric component while copying the text component. 
You can also extend dates in this way, using a number of date formats, including Qtr 1, 
Qtr 2, and so on. If you type text that describes dates, even without numbers (such as 
months or days of the week), Excel treats the text as a series.
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INSIDE OUT   Fill series limited to 255 characters

Excel lets you type up to 32,767 characters in a cell . However, if you want to extend a 
series using Auto Fill, the selected source cells cannot contain more than 255 charac-
ters . If you try to extend a series from an entry of 256 characters or more, Excel copies 
the cells instead of extending the series . This is not really a bug but a side effect of the 
Excel column-width limitation of 255 characters . Besides, a 256-character entry is not 
going to be readable on the screen anyway . If you really need to create a series out of 
humongous cell entries like this, perhaps a little worksheet redesign is in order . Other-
wise, you have to do it manually .

Figure 8-23 shows some examples of simple data series created by selecting single cells 
containing values and dragging the fill handle. We typed the values in column A, and we 
extended the values to the right of column A using the fill handle. Figure 8-24 shows exam-
ples of creating data series using two selected values that, in effect, specify the interval to 
be used in creating the data series. We typed the values in columns A and B and extended 
the values to the right of column B using the fill handle. These two figures also show how 
Auto Fill can create a series even when you mix text and numeric values in cells. Also note 
that we extended the values and series in Figure 8-24 by selecting the entire range of start-
ing values in cells A3:B12 before dragging the fill handle to extend them, showing how 
Excel can extend multiple series at once. (We applied the bold formatting after filling to 
make it easier to differentiate the starting values.)

Figure 8-23 Create simple data series by selecting a single value and dragging the fill handle.




