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CHAPTER 6

How to work a worksheet

in thiS Chapter, we cover the basics, including moving around within the massive work-
sheet grid, entering and selecting data, and working with multiple worksheets and pro-
tecting their contents. You probably already know many of these techniques, but here 

you’ll also learn alternative methods. You might find a better—or faster—way to do some-
thing you do frequently.

Moving around regions
A region is a rectangular range of cell entries, or a block of “filled” cells. In Figure 6-1, the 
range A3:E7 is a region, as are the ranges G3:H7, A9:E10, and G9:H10. (Strictly speaking, cell 
A1 is a one-cell region, too.) Cell H10 is considered to be within a region, even though it’s 
empty. 

The active area of the worksheet is the selection rectangle that encompasses all regions—
that is, all the filled cells in the active worksheet—which in Figure 6-1 is A1:H10.

The techniques you can use to navigate regions are helpful if you typically work with large 
tables of data. Getting to the bottom row of a 500-row table is easier when you don’t have 
to use the scroll bars.

Note
The small square in the lower-right corner of the active cell is the fill handle. If the fill 
handle isn’t visible on your screen, it means it isn’t turned on . To turn it on, click the 
File tab, click Options, click the Advanced category, and select the Enable Fill Handle 
And Cell Drag-And-Drop check box .
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Figure 6-1 There are four regions—blocks of “filled” cells—on this worksheet that are separate 
regions.

Navigating regions with the keyboard
Here is a great way to move around fast without taking your hands off the keyboard. To 
jump from edge to edge within and between regions, hold down the Ctrl key and then 
press any of the arrow keys. For example, in Figure 6-1, cell A3 is the active cell; press 
Ctrl+Right Arrow to activate cell E3. Press Ctrl+Right Arrow again and the active cell 
jumps to G3, then H3, and finally XFD3—the last available cell in row 3. Just keep pressing 
Ctrl+Left Arrow to return. 

Navigating regions with the mouse
The dark border around the selected cell or cells is called a selection rectangle. When you 
move the plus-sign pointer over the selection rectangle, the pointer becomes a four-
headed arrow. When the arrow pointer is visible, double-click to jump from edge to edge 
among regions—the mouse equivalent of the Ctrl+Arrow keyboard method described 
earlier. For example, double-clicking the bottom of the single-cell selection rectangle in cell 
A3, as shown in Figure 6-1, selects cell A7.

The left side of the status bar displays the mode indicators in Table 6-1 when the corre-
sponding keyboard mode is active. 

TABLE 6-1 Keyboard modes

Mode Description

Extend 
Selection

Press F8 to turn on this mode, which you use to extend the current selection 
using the keyboard. (Be sure that Scroll Lock is off.) This is the keyboard 
equivalent of selecting cells by dragging the mouse. Furthermore, unlike 
holding down the Shift key and pressing an arrow key, you can extend the 
range by pressing only one key at a time. Press F8 again to turn off Extend 
Selection mode.
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Mode Description

Add To 
Selection

Press Shift+F8 to add more cells to the current selection using the keyboard; 
the cells need not be adjacent. After pressing Shift+F8, click any cell or drag 
through any range to add it to the selection. This is the keyboard equivalent of 
holding down Ctrl and selecting additional cells with the mouse.

Num Lock This mode keeps your keypad in numeric entry mode. This is turned on by 
default, but its status is not usually displayed in the status bar. However, you 
can make it do so by right-clicking the status bar anywhere and clicking Num 
Lock.

Fixed 
Decimal

To add a decimal point to the numeric entries in the current selection, click 
the File tab, click Options, select the Advanced category, and select the 
Automatically Insert A Decimal Point check box in the Editing Options group. 
Excel places the decimal point in the location you specify in the Places box. For 
example, when you turn on Fixed Decimal mode, specify two decimal places, 
and type the number 12345 in a cell, the value 123.45 appears in the cell after 
you press Enter. Existing cell entries are not affected unless you edit them. To 
turn off Fixed Decimal mode, return to the Advanced category in the Excel 
Options dialog box and clear the Automatically Insert A Decimal Point check 
box.

Caps Lock Press the Caps Lock key to type text in capital letters. (This does not affect 
number and symbol keys.) To turn off Caps Lock mode, press the Caps Lock 
key again. The status of this mode does not usually display in the status bar, 
but you can make it do so. Right-click the status bar anywhere, and click Caps 
Lock.

Scroll Lock Press Scroll Lock to use the Page Up, Page Down, and arrow keys to move the 
viewed portion of the window without moving the active cell. When Scroll 
Lock mode is off, the active cell moves one page at a time when you press 
Page Up or Page Down and moves one cell at a time when you press one of 
the arrow keys. To turn off Scroll Lock mode, press the Scroll Lock key again.

End Press the End key, and then press an arrow key to move the selection to 
the edge of the region in that direction or to the last worksheet cell in that 
direction. This mode functions like holding down Ctrl and pressing an arrow 
key, except you need to press only one key at a time. To turn off End mode, 
press the End key again. End mode is also turned off after you press one of the 
arrow keys.

Overtype Click the formula bar or double-click a cell and press the Insert key to turn on 
Overtype mode (formerly known as Overwrite mode). Usually, new characters 
you type in the formula bar are inserted between existing characters. With 
Overtype mode turned on, the characters you type replace any existing 
characters to the right of the insertion point. Overtype mode turns off when 
you press Insert again or when you press Enter or one of the arrow keys to 
lock in the cell entry. The status of this mode does not usually display in the 
status bar, but you can make it do so. Right-click the status bar anywhere, and 
click Overtype Mode.
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Navigating with special keys
Table 6-2 shows how you can use the Home and End keys alone and in conjunction with 
other keys to make selections and to move around a worksheet.

TABLE 6-2 Keyboard shortcuts for navigation

Press To

Home Move to the first cell in the current row.
Ctrl+Home Move to cell A1.
Ctrl+End Move to the last cell in the last column in the active area. For 

example, in Figure 6-1, pressing Ctrl+End selects cell H10.
End Start End mode, and then press an arrow key to move around 

by cell region. 
Scroll Lock+Home Move to the first cell within the current window.
Scroll Lock+End Move to the last cell within the current window.

Understanding selection
As you will see, there are many ways beyond a simple click-and-drag to isolate the par-
ticular types of data, formats, objects, and even blank cells that you need to gather or edit. 
Here are a few pertinent facts and definitions to start with:

 ● While a region is defined as a rectangular block of filled cells, a range is any rectangle 
of cells, filled or empty.

 ● Before you can work with a cell or range, you must select it, and when you do, it 
becomes active.

 ● The reference of the active cell appears in the Name box at the left end of the for-
mula bar.

 ● You can select ranges of cells, but only one cell can be active at a time. The active 
cell always starts in the upper-left corner of the range, but you can move it without 
changing the selection.

 ● Select all cells on a worksheet by clicking the Select All box located in the upper-left 
corner of your worksheet, where the column and row headings intersect.

For more about selection, read on.
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Selecting with the mouse
To select a range of cells, drag the mouse pointer over the range. Or select a cell at one 
corner, and then press Shift and click the cell at the diagonal corner of the range. For exam-
ple, with cells A1:B5 selected, hold down the Shift key and click cell C10 to select A1:C10. 
When you need to select a large range, this technique is more efficient than dragging the 
mouse pointer across the entire selection.

Zooming to select large worksheet areas

You can zoom out for a bird’s-eye view of a large worksheet, as shown in Figure 6-2. Drag 
the Zoom slider at the bottom of the screen to the left, or click the Zoom percentage indi-
cator adjacent to the slider to open the Zoom dialog box for more zooming options. The 
Zoom feature is limited to a range from 10 through 400 percent. 

Figure 6-2 Use the Zoom slider or the Zoom dialog box to view large areas of a worksheet for 
easier selection.
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Selecting columns, rows, and nonadjacent ranges

A nonadjacent range (also known as multiple or noncontiguous) comprises more than one 
selection rectangle, as shown in Figure 6-3. To select multiple ranges with the mouse, press 
the Ctrl key and drag through each range you want to select. The first cell you click in the 
last range you select becomes the active cell. As you can see in Figure 6-3, cell G6 is the 
active cell.

Figure 6-3 Hold down the Ctrl key and drag to select nonadjacent ranges with the mouse 
pointer.

Use the following methods to select using the mouse:

 ● To select an entire column or row, click the column or row heading. The first visible 
cell in the column becomes the active cell. If the first row visible on your screen is 
row 1000, cell A1000 becomes active when you click the heading for column A, even 
though all the other cells in the column are selected. 

 ● To select more than one adjacent column or row at a time, drag through the column 
or row headings, or click the heading at one end of the range, press Shift, and then 
click the heading at the other end. 

 ● To select nonadjacent columns or rows, hold down Ctrl and click each heading or 
drag through adjacent headings you want to select. 

In Figure 6-4, we clicked the heading in column A and then pressed Ctrl while dragging 
through the headings for rows 1, 2, and 3.
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Figure 6-4 Select entire columns and rows by clicking their headings, or hold down the Ctrl key 
while clicking to select nonadjacent rows and columns.

Use the following methods to select with the keyboard:

 ● To select an entire column with the keyboard, select any cell in the column and press 
Ctrl+Spacebar.

 ● To select an entire row with the keyboard, select any cell in the row and press 
Shift+Spacebar.

 ● To select several entire adjacent columns or rows with the keyboard, select any cell 
range that includes cells in each of the columns or rows and then press Ctrl+Spacebar 
or Shift+Spacebar, respectively. For example, to select columns B, C, and D, select 
B4:D4 (or any range that includes cells in these three columns) and then press 
Ctrl+Spacebar.

 ● To select the entire worksheet with the keyboard, press Ctrl+Shift+Spacebar.

Selecting regions

If you hold down the Shift key while navigating regions (as described in “Navigating 
regions with the keyboard” earlier in this chapter), Excel selects all the cells in between. For 
example, if cell A3 was the only cell selected in the worksheet shown in Figure 6-4, holding 
the Shift key while pressing Ctrl+Right Arrow would select the range A3:E3, and then, still 
holding Shift, pressing Ctrl+Down Arrow would select the range A3:E7. 
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Using the find and select commands
At the right end of the Home tab on the ribbon, the Find & Select menu displays several 
helpful selection commands, as shown in Figure 6-5. In the middle of the menu are five 
commands that used to be buried in dialog boxes back in the old days, but they’ve more 
recently been promoted to the ribbon because of their widespread use: Formulas, Com-
ments, Conditional Formatting, Constants, and Data Validation.

Figure 6-5 Use the Find & Select commands to zero in on specific items.

In Figure 6-5, we used the Formulas command to select all the formulas on the worksheet, 
which are highlighted by multiple selection rectangles. You can use these specialized selec-
tion commands for various purposes, such as applying specific formatting to formulas and 
constants or auditing worksheets for errant conditional formatting or data-validation cells.

The two Go To commands on the Find & Select menu are also helpful for finding and 
selecting a variety of worksheet elements. To quickly move to and select a cell or a range 
of cells, click Go To (or press F5) to open the Go To dialog box; then type a cell reference, 
range reference, or defined range name in the Reference box, and press Enter. You can also 
extend a selection using Go To. For example, to select A1:Z100, you can click A1, open the 
Go To dialog box, type Z100, and then press Shift+Enter.

For more about selecting, see “Finding and replacing stuff” in Chapter 8, “Worksheet editing 
techniques,” and “Selecting and grouping objects” in Chapter 10, “Creating and formatting 
graphics.” For more information about defined range names and references, see “Nam-
ing cells and cell ranges” and “Using cell references in formulas” in Chapter 12, “Building 
formulas .”

To move to another worksheet in the same workbook, open the Go To dialog box, and type 
the name of the worksheet, followed by an exclamation point and a cell name or reference. 
For example, to go to cell A1 on a worksheet called Sheet3, type Sheet3!A1. To move to 
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another worksheet in another open workbook, open the Go To dialog box and type the 
name of the workbook in brackets, followed by the name of the worksheet, an exclama-
tion point, and a cell name or reference. For example, to go to cell H10 on a worksheet 
called Sheet2 in an open workbook called Regional Sales.xlsx, type '[Regional Sales.xlsx]
Sheet2'!D5. (Note that because there is a space in the name of the workbook, you must 
enclose the entire sheet reference in single quotation marks.)

Excel keeps track of the last four locations from which you used the Go To command and 
lists them in the Go To dialog box. You can use this list to move among these locations 
in your worksheet. This is handy when you’re working on a large worksheet or jumping 
around among multiple locations and worksheets in a workbook. Figure 6-6 shows the Go 
To dialog box displaying several previous locations.

Figure 6-6 The Go To and Go To Special dialog boxes are your selection transporters.

Note
In the Go To dialog box, Excel displays in the Reference box the cell or range from 
which you just moved . This way, you can easily move back and forth between two loca-
tions by pressing F5 and then Enter repeatedly .

Selecting with Go To Special
When you click the Special button in the Go To dialog box (or the Go To Special com-
mand on the Find & Select menu), the dialog box shown on the right of Figure 6-6 opens, 
presenting additional selection options. You can think of the Go To Special dialog box as 



Chapter 6

140 Chapter 6 How to work a worksheet

“Select Special” because you can use it to quickly find and select cells that meet certain 
specifications.

After you specify one of the Go To Special options and click OK, Excel highlights the cell or 
cells that match the criteria. With a few exceptions, if you select a range of cells before you 
open the Go To Special dialog box, Excel searches only within the selected range; if the cur-
rent selection is a single cell or one or more graphic objects, Excel searches the entire active 
worksheet. The following are guidelines for using the Go To Special options:

 ● Constants Refers to any cell containing static data, such as numbers or text, but not 
formulas.

 ● Current Region Handy when you’re working in a large, complex worksheet and 
need to select blocks of cells. (Recall that a region is defined as a rectangular block of 
cells bounded by blank rows, blank columns, or worksheet borders.)

 ● Current Array Selects all the cells in an array if the selected cell is part of an array 
range.

 ● Last Cell Selects the cell in the lower-right corner of the range that encompasses 
all the cells that contain data, comments, or formats. When you select Last Cell, Excel 
finds the last cell in the active area of the worksheet, not the lower-right corner of the 
current selection.

 ● Visible Cells Only Excludes from the current selection any cells in hidden rows or 
columns.

 ● Objects Selects all graphic objects in your worksheet, regardless of the current 
selection.

 ● Conditional Formats Selects only cells that have conditional formatting applied. 
You can also click the Home tab and then click the Conditional Formatting command 
on the Find & Select menu.

 ● Data Validation Using the All option, selects all cells to which data validation has 
been applied; Data Validation using the Same option selects only cells with the same 
validation settings as the currently selected cell. You can also click the Home tab and 
then click the Data Validation command on the Find & Select menu, which uses the 
All option.

For more information about graphic objects, see Chapter 10 . For more information about 
conditional formatting, see “Formatting conditionally” in Chapter 9, “Worksheet formatting 
techniques .”
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Navigating multiple selections
Some of the Go To Special options—such as Formulas, Comments, Precedents, and 
Dependents—might cause Excel to select multiple nonadjacent ranges . But you might 
want to change the active cell without losing the multiselection . Or you might want to 
type entries into multiple ranges that you preselect so that you don’t have to reach for 
the mouse . Either way, you can move among cells within ranges, and between ranges, 
without losing the selection . For example, the worksheet shown here has three ranges 
selected:

To move the active cell through these ranges without losing the selection, press Enter 
to move down or to the right one cell at a time; press Shift+Enter to move up or to the 
left one cell at a time . Or press Tab to move to the right or down; press Shift+Tab to 
move to the left or up . So, in this worksheet, if you press Enter until cell A17 is selected, 
the next time you press Enter the selection jumps to the beginning of the next selected 
region—in this case, cell A1 . Subsequently pressing Enter selects A2, then B1, then B2, 
and so on, moving down and across until the end of the region (cell F2), and then to 
the next region (cell B4) .

Selecting precedents and dependents

The Precedents and Dependents options in the Go To Special dialog box let you find all 
cells that are used by a formula or to find all cells upon which a formula depends. To use 
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the Precedents and Dependents options, first select the cell whose precedents or depen-
dents you want to find. When searching for precedents or dependents, Excel always 
searches the entire worksheet. When you select the Precedents or Dependents option, Excel 
activates the Direct Only and All Levels options:

 ● Direct Only finds only cells that directly refer to or that directly depend on the active 
cell.

 ● All Levels locates direct precedents and dependents plus cells indirectly related to the 
active cell.

Depending on the task, you might find the built-in auditing features of Excel to be just 
the trick. On the Formulas tab on the ribbon, the Formula Auditing group offers the Trace 
Precedents and Trace Dependents buttons. Rather than selecting all such cells, as the Go To 
Special command does, clicking these buttons draws arrows showing path and direction in 
relation to the selected cell. 

For more information, see “Auditing and documenting worksheets” in Chapter 8 .

Go To Special keyboard shortcuts
If you do a lot of “going to,” you’ll want to learn a few of these keyboard shortcuts, 
which speed things up considerably:

 ● Press Ctrl+Shift+* to select the current region .

 ● Press Ctrl+/ to select the current array .

 ● Press Alt+; to select the visible cells only .

 ● Press Ctrl+[ to select the direct precedents .

 ● Press Ctrl+Shift+{ to select all the precedents .

 ● Press Ctrl+] to select the direct dependents .

 ● Press Ctrl+Shift+} to select all the dependents .

 ● Press Ctrl+\ to select row differences .

 ● Press Ctrl+Shift+| to select column differences .
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Selecting row or column differences

The Row Differences and Column Differences options in the Go To Special dialog box com-
pare the entries in a range of cells to spot potential inconsistencies. To use these debugging 
options, select the range before displaying the Go To Special dialog box. The position of 
the active cell in your selection determines which cells Excel uses to make its comparisons. 
When searching for row differences, Excel compares the cells in the selection with the cells 
in the same column as the active cell. When searching for column differences, Excel com-
pares the cells in the selection with the cells in the same row as the active cell.

In addition to other variations, the Row Differences and Column Differences options look 
for differences in references and select cells that don’t conform to the comparison cell. 
They also verify that all the cells in the selected range contain the same type of entries. For 
example, if the comparison cell contains a SUM function, Excel flags any cells that contain a 
function, formula, or value other than SUM. If the comparison cell contains a constant text 
or numeric value, Excel flags any cells in the selected range that don’t match the compari-
son value. The options, however, are not case-sensitive.

Techniques for entering data
Excel accepts two types of cell entries: constants and formulas. Constants fall into three 
main categories: numeric values, text values (also called labels or strings), and date/time 
values. Excel also recognizes two special types of constants, called logical values and error 
values.

For more about date/time values, see Chapter 15, “Formatting and calculating date and time .”

Making entries in cells and in the formula bar
In “classic” versions of Excel, all entries and edits happened only in the formula bar; later, in-
cell editing was added, and subtle behavioral differences still remain between these modes 
of entry. 

To make an entry in a cell, just select the cell and start typing. As you type, the entry 
appears both in the formula bar and in the active cell. The flashing vertical bar in the active 
cell is called the insertion point. 

After you finish typing, you must press Enter to lock in the entry to store it permanently 
in the cell. Pressing Enter normally causes the active cell to move down one row. You can 
change this so that when you press Enter, either the active cell doesn’t change or it moves 
to an adjacent cell in another direction. Click the File tab, click Options, select the Advanced 



Chapter 6

144 Chapter 6 How to work a worksheet

category, and either clear the After Pressing Enter, Move Selection check box or change 
the selection in the Direction drop-down list. You also lock in an entry when you move the 
selection to a different cell by pressing Tab, Shift+Tab, Shift+Enter, or an arrow key, among 
other methods, after you type the entry, as described in Table 6-3.

TABLE 6-3 Keyboard shortcuts for data entry

Press To

Enter Activate the cell below the active cell, or whatever direction you have 
selected for the After Pressing Enter, Move Selection option in the 
Advanced category in the Excel Options dialog box.

Shift+Enter Activate the cell above the active cell, or the opposite of the direction 
set for the After Pressing Enter, Move Selection option in the Advanced 
category in the Excel Options dialog box.

Tab Activate the cell one column to the right of the active cell.
Shift+Tab Activate the cell one column to the left of the active cell.
Arrow Key Activate the adjacent cell in the direction of the arrow key you press.

When you begin typing an entry, three buttons appear on the formula bar: Cancel, Enter, 
and Insert Function. When you type a formula in which the entry begins with an equal 
sign (=), a plus sign (+), or a minus sign (–), a drop-down list of frequently used functions 
becomes available, as shown in Figure 6-7.

For more about editing formulas, see Chapter 12 .

Cancel
Functions list Insert Function

Enter

Figure 6-7 When you start entering a formula by typing an equal sign, the formula bar offers 
ways to help you finish it.
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Entering simple numeric and text values

An entry that includes only the numerals 0 through 9 and certain special characters—such 
as + – E e ( ) . , $ % and /—is a numeric value. An entry that includes almost any other char-
acter is a text value. Table 6-4 lists some examples of numeric and text values.

TABLE 6-4 Examples of numeric and text values

Numeric values Text values

123 Sales
123.456 B-1
$1.98 Eleven
1% 123 Main Street
1.23E+12 No. 324

Using special characters

A number of characters have special effects in Excel. Here are some guidelines for using 
special characters:

 ● If you begin a numeric entry with a plus sign, Excel drops the plus sign.

 ● If you begin a numeric entry with a minus sign, Excel interprets the entry as a nega-
tive number and retains the sign.

 ● In a numeric entry, the characters E and e specify an exponent used in scientific nota-
tion. For example, Excel interprets 1E6 as 1,000,000 (1 times 10 to the sixth power), 
which is displayed in Excel as 1.00E+06. To enter a negative exponential number, type 
a minus sign before the exponent. For example, 1E–6 (1 times 10 to the negative 
sixth power) equals .000001 and is displayed in Excel as 1.00E–06.

 ● Excel interprets numeric constants enclosed in parentheses as negative numbers, 
which is a common accounting practice. For example, Excel interprets (100) as –100.

 ● You can use decimal points and commas as you normally would. When you type 
numbers that include commas as separators, however, the commas appear in the 
cell but not in the formula bar. This is the same effect as when you apply one of the 
built-in Excel Number formats. For example, if you type 1,234.56, the value 1234.56 
appears in the formula bar.

 ● If you begin a numeric entry with a dollar sign ($), Excel assigns a Currency format 
to the cell. For example, if you type $123456, Excel displays $123,456 in the cell and 
123456 in the formula bar. In this case, Excel adds the comma to the worksheet dis-
play because it’s part of the Currency format.
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 ● If you end a numeric entry with a percent sign (%), Excel assigns a Percentage format 
to the cell. For example, if you type 23%, Excel displays 23% in the formula bar and 
assigns a Percentage format to the cell, which also displays 23%.

 ● If you use a slash (/) in a numeric entry and the string cannot be interpreted as a 
date, Excel interprets the number as a fraction. For example, if you type 11 5/8 (with 
a space between the number and the fraction), Excel assigns a Fraction format to the 
entry, meaning the formula bar displays 11.625 and the cell displays 11 5/8.

Note
To be sure that Excel does not interpret a fraction as a date, precede the fraction with 
a zero and a space . For example, to prevent Excel from interpreting the fraction 1/2 as 
January 2, type 0 1/2 .

For more about the built-in Excel Number formats, see “Formatting in depth” in Chapter 9 . 
For more information about date and time formats, see “How AutoFill handles dates and 
times” in Chapter 8 .

Understanding the difference between displayed values and 
underlying values

Although you can type 32,767 characters in a cell, a numeric cell entry can maintain preci-
sion to a maximum of only 15 digits. This means you can type numbers longer than 15 
digits in a cell, but Excel converts any digits after the 15th to zeros. If you are working with 
figures greater than 999 trillion or decimals smaller than trillionths, perhaps you need to 
look into alternative solutions, such as a Cray supercomputer!

If you type a number that is too long to appear in a cell, Excel converts it to scientific nota-
tion in the cell if you haven’t applied any other formatting. Excel adjusts the precision of 
the scientific notation depending on the cell width. If you type a very large or very small 
number that is longer than the formula bar, Excel displays it in the formula bar using scien-
tific notation. In Figure 6-8, we typed the same number in cell A1 and cell B1; because cell 
B1 is wider, Excel displays more of the number but still displays it using scientific notation.
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Figure 6-8 Because the number 123,456,789,012 is too long to fit in cell A1, Excel displays it in 
scientific notation.

For more information about increasing the width of a cell, see “Changing column widths” in 
Chapter 9 .

The values that appear in formatted cells are called displayed values; the values that are 
stored in cells and appear in the formula bar are called underlying values. The number of 
digits that appear in a cell—its displayed value—depends on the width of the column and 
any formatting you apply to the cell. If you reduce the width of a column that contains a 
long entry, Excel might display a rounded version of the number, a string of number signs 
(#), or scientific notation, depending on the display format you’re using.

Note
If you see a series of number signs (######) in a cell where you expect to see a num-
ber, increase the width of the cell to see the numbers again .

TROUBLESHOOTING
My formulas don’t add numbers correctly
Suppose, for example, you write a formula and Excel tells you that $2 .23 plus $5 .55 
equals $7 .79, when it should be $7 .78 . Investigate your underlying values . If you use 
currency formatting, numbers with more than three digits to the right of the decimal 
point are rounded to two decimal places . In this example, if the underlying values are 
2 .234 and 5 .552, the result is 7 .786, which rounds to 7 .79 . You can either change the 
decimal places or select the Set Precision As Displayed check box (click the File tab, 
click Options, click the Advanced category, and look in the When Calculating This 
Workbook area) to eliminate the problem . Be careful if you select Set Precision As 
Displayed, however, because it permanently changes all the underlying values in your 
worksheet to their displayed values . 
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Creating long text values

If you type text that is too long for Excel to display in a single cell, the entry spills into adja-
cent cells if they are empty, but the text remains stored in the original cell. If you then type 
text in a cell that is overlapped by another cell, the overlapped text appears truncated, as 
shown in cell A3 in Figure 6-8. But don’t worry—it’s still all there. 

Note
The easiest way to eliminate overlapping text is to widen the column by double- 
clicking the column border in the heading . For example, in Figure 6-8, when you 
 double-click the line between the A and the B in the column headings, the width of 
column A adjusts to accommodate the longest entry in the column .

Using text wrapping

If you have long text entries, text wrapping can make them easier to read. Text wrapping 
lets you enter long strings of text that wrap onto two or more lines within the same cell 
rather than overlap adjacent cells. Select the cells where you want to use wrapping, and 
then click the Home tab on the ribbon and click the Wrap Text button, as shown in Fig-
 ure 6-9. To accommodate the extra lines, Excel increases the height of the row.

Figure 6-9 Click the Wrap Text button to force long text entries to wrap within a single cell.

For more about wrapping text, see “Wrapping text in cells” in Chapter 9 .
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Understanding numeric text entries

Sometimes you might want to type special characters that Excel does not normally treat as 
plain text. For example, you might want +1 to appear in a cell. If you type +1, Excel inter-
prets this as a numeric entry and drops the plus sign (as stated earlier). In addition, Excel 
normally ignores leading zeros in numbers, such as 01234. You can force Excel to accept 
special characters as text by using numeric text entries.

To enter a combination of text and numbers, such as G234, just type it. Because this entry 
includes a nonnumeric character, Excel interprets it as a text value. To create a text entry 
that consists entirely of numbers, you can precede the entry with a text-alignment prefix 
character, such as an apostrophe. You can also enter it as a formula by typing an equal sign 
and enclosing the entry with quotation marks. For example, to enter the number 01234 
as text so that the leading zero is displayed, type either '01234 or ="01234" in a cell. 
Whereas numeric entries are normally right-aligned, a numeric text entry is left-aligned in 
the cell, just like regular text, as shown in Figure 6-10.

Figure 6-10 We typed the policy numbers in column A as text.

Text-alignment prefix characters, like formula components, appear in the formula bar but 
not in the cell. Table 6-5 lists all the text-alignment prefix characters.

Only the apostrophe text-alignment prefix character always works with numeric or text 
entries. The caret, backslash, and quotation mark characters work only if Transition 
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Navigation Keys are turned on. To do so, click the File tab, click Options, select the 
Advanced category, and then scroll down to the Lotus Compatibility area and select the 
Transition Navigation Keys check box.

TABLE 6-5 Text-alignment prefix characters

Character Action

' (apostrophe) Left-aligns data in the cell.
" (quotation mark) Right-aligns data in the cell. (See the following note.)
^ (caret) Centers data in the cell. (See the following note.)
 \ (backslash) Repeats characters across the cell. (See the following note.)

You’ll find the Humongous.xlsx file with the other examples on the companion website.

When you create a numeric entry that starts with an alignment prefix character, a small 
flag appears in the upper-left corner of the cell, indicating that the cell has a problem you 
might need to address. When you select the cell, an error button appears to the right. 
Clicking this button displays a menu of specific commands. (Refer to Figure 6-10.) Because 
the apostrophe was intentional, you can click Ignore Error.

Note
If a range of cells shares the same problem, as in column A in Figure 6-10, you can 
select the entire cell range and use the action menu to resolve the problem in all the 
cells at the same time . For more information, see “Using custom AutoCorrect actions” 
in Chapter 8 .

Entering symbols

If you ever want to use characters in Excel that are not on your standard computer key-
board, you’re in luck. Click the Insert tab on the ribbon, and in the Symbols group, click the 
Symbol button to gain access to the complete character set for every installed font on your 
computer. Figure 6-11 shows the Symbol dialog box.
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Figure 6-11 You can insert characters from the extended character sets of any installed font.

On the Symbols tab, select the font from the Font drop-down list; the entire character set 
appears. You can jump to specific areas in the character set by using the Subset drop-down 
list, which also indicates the area of the character set you are viewing if you are using the 
scroll bar to browse through the available characters. The Character Code box displays the 
code for the selected character. You can also highlight a character in the display area by 
typing the character’s code number. You can select decimal or hexadecimal ASCII character 
encoding or Unicode by using the From drop-down list. If you choose Unicode, you can 
select from a number of additional character subsets in the Subset drop-down list. The 
 Special Characters tab in the Symbol dialog box gives you quick access to a number of 
commonly used characters, such as the em dash, the ellipsis, and the trademark and copy-
right symbols.

Making entries in ranges
To make a number of entries in a range of adjacent cells, first select all of them. Then just 
begin typing entries, as shown in Figure 6-12. Each time you press Enter, the active cell 
moves to the next cell in the range, and the range remains selected. When you reach the 
edge of the range and press Enter, the active cell jumps to the beginning of the next col-
umn or row. You can continue making entries this way until you fill the entire range.
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Figure 6-12 You can easily make entries in a range of cells by first selecting the entire range.

Note
To enter the same value in all selected cells at once, type your first entry and then press 
Ctrl+Enter .

Editing and undoing entries
You can correct simple errors as you type by pressing Backspace. However, to make 
changes to entries you have already locked in, you first need to enter Edit mode. (The 
mode indicator at the lower-left corner of the status bar has to change from Ready to Edit.) 
To enter Edit mode, do one of the following:

 ● Double-click the cell, and position the insertion point at the location of the error.

 ● Select the cell, and press F2. Use the arrow keys to position the insertion point within 
the cell.

To select contiguous characters within a cell, place the insertion point just before or just 
after the characters you want to replace, and press Shift+Left Arrow or Shift+Right Arrow 
to extend your selection.

Note
If you don’t want to take your hands off the keyboard to move from one end of a cell 
entry to the other, press Home or End while in Edit mode . To move through an entry 
one “word” at a time, press Ctrl+Left Arrow or Ctrl+Right Arrow .

If you need to erase the entire contents of the active cell, press Delete, or press Backspace 
and then Enter. If you press Backspace accidentally, click the Cancel button or press Esc to 
restore the contents of the cell before pressing Enter. You can also erase the entire contents 
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of a cell by selecting the cell and typing new contents to replace the old. To revert to the 
original entry, press Esc before you press Enter.

You can always click the Undo button in the Quick Access Toolbar; alternatively, press 
Ctrl+Z. The Undo button remembers the last 100 actions you performed. If you press 
Ctrl+Z repeatedly, each of the last actions is undone, one after the other, in reverse order. 
You can also click the small arrow next to the Undo button to display a list of remembered 
actions. Drag the mouse to select one or more actions, as shown in Figure 6-13. After you 
release the mouse, all the selected actions are undone. The Redo button works the same 
way; you can quickly redo what you have just undone, if necessary.

Undo Redo

Figure 6-13 Click the small arrow next to the Undo button to select any number of the last 100 
actions to undo at once.

Note
You can’t undo individual actions in the middle of the Undo list . If you select an action, 
all actions up to and including that action are undone .
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Floating option buttons
There are several types of “floating” option buttons that appear as you work in Excel. 
These are provided to give you instant access to commands and actions that are rel-
evant to the current task . Many editing actions trigger the display of an option but-
ton . For example, copying and pasting cells causes the Paste Options button to appear 
adjacent to the last cell edited . If you click the button, a menu offers retroactive editing 
options:

Floating option buttons appear in many situations, so you will hear about them in 
other places in this book . For examples, see “Tracing errors” and “Pasting selectively 
using Paste Special” in Chapter 8, and “Entering a series of dates” in Chapter 15 .

Managing worksheets
You can have as many worksheets in a workbook as your computer’s memory will allow 
(probably hundreds of worksheets, depending on how much data each contains); conse-
quently, you don’t need to try to fit everything onto one worksheet. The following sections 
present the features you can use to organize your worksheet world.

Inserting and deleting worksheets
To insert a new worksheet into an existing workbook, click the New Sheet button, which 
you can see at the left of Figure 6-14. The new sheet tab appears to the right of the last 
worksheet in the workbook. You can also quickly insert worksheets by right-clicking any 
sheet tab to display the shortcut menu shown at the right in Figure 6-14. Clicking Insert on 
this menu opens the Insert dialog box, which contains other items you can insert besides 
blank worksheets, including templates and Excel 4 macro sheets.
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Figure 6-14 To insert a blank worksheet, click the New Sheet button, or right-click any sheet tab 
to display a worksheet-focused shortcut menu.

In addition to providing a convenient method for inserting, deleting, renaming, moving, 
and copying worksheets, this shortcut menu contains the Select All Sheets command. As its 
name indicates, you use this command to select all the worksheets in a workbook, which 
you need to do to perform certain functions, such as copying or formatting, on all the 
worksheets at once. The View Code command on this shortcut menu launches the Visual 
Basic Editor, showing the Code window for the current worksheet.

For more information about the Visual Basic Editor, see Chapter 28, “Recording macros .”

Note
As you can see in the shortcut menu shown in Figure 6-14, the sheet tab shortcut 
menu also contains a Tab Color command . If you are a visually oriented person, you 
might find color-coding your worksheet tabs to be as useful as changing the worksheet 
names .

You can also add multiple worksheets to a workbook at the same time (starting with a 
workbook with multiple sheets in it). To do so, click a sheet tab, press Shift, and then click 
other sheet tabs to select a range of worksheets—the same number you want to insert—
before clicking Insert Worksheet on the sheet tab shortcut menu. (Notice that Excel adds 
[Group] to the workbook title in the window title bar, indicating you have selected a group 
of worksheets for editing.) Excel inserts the new worksheets in front of the first worksheet in 
the selected range. Note that this does not copy the selected worksheets; it is just a way of 
telling Excel how many fresh, blank worksheets you want to insert at once.

For more information about group editing, see “Editing multiple worksheets” in Chapter 8 .
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You cannot undo the insertion of a new worksheet. If you do need to delete a worksheet, 
right-click its sheet tab and click Delete. If you want to delete more than one worksheet, 
you can hold down Shift to select a range of worksheets, or you can hold down Ctrl and 
select nonadjacent worksheets, before you click Delete. 

CAUTION!
Be careful! You cannot retrieve a worksheet after you delete it .

Naming and renaming worksheets
Notice that Excel numbers the new worksheets based on the number of worksheets in 
the workbook. If your workbook contains one worksheet, the first worksheet you insert is 
Sheet2, the next is Sheet3, and so on. If you grow weary of seeing Sheet1, Sheet2, and so 
on in your workbooks, you can give your worksheets more imaginative and helpful names 
by double-clicking the tab and typing a new name.

You can use up to 31 characters in your worksheet names. Nevertheless, you should 
remember that the name you use determines the width of the corresponding sheet tab, as 
shown in Figure 6-15. Therefore, you might want to keep your worksheet names concise so 
that you can see more than a couple of sheet tabs at a time.

Figure 6-15 Double-click the sheet tab to type a new name. You might want to keep it short.

Moving and copying worksheets
As you might expect, Excel provides an easy way to move a worksheet from one place to 
another in the same workbook. In fact, all you have to do is click a sheet tab to select it and 
then drag it to its new location. Figure 6-16 shows this process. When you drag a work-
sheet, a small worksheet icon appears, and a tiny arrow indicates where the worksheet will 
be inserted in the tab order.
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Figure 6-16 Click and drag sheet tabs to rearrange worksheets.

When you move worksheets, remember the following tips:

 ● If you want to move a worksheet to a location that isn’t currently visible on your 
screen, drag past the visible tabs in either direction. The sheet tabs scroll in the direc-
tion you drag.

 ● You can move several worksheets at the same time. When you select several work-
sheets and drag, the worksheet pointer icon changes to look like a small stack of 
pages.

 ● You can copy worksheets using similar mouse techniques. First, select the worksheets 
you want to copy, and then hold down Ctrl while you drag the worksheets to the new 
location. 

 ● When you copy a worksheet, an identical worksheet appears in the new location. 
Excel appends a number in parentheses to the copy’s name to distinguish it from the 
original worksheet. For example, making a copy of Sheet1 results in a new worksheet 
named Sheet1 (2).

 ● You can select nonadjacent worksheets by pressing Ctrl while you click to select the 
sheet tabs. Then you can click any selected tab and drag to move the group, or click, 
press Ctrl, and drag to create copies.

 ● You can click Move Or Copy on the sheet tab shortcut menu to handle similar work-
sheet management functions, including moving and copying worksheets between 
workbooks.
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Dragging worksheets between workbooks
You can move and copy worksheets between workbooks by dragging . You use the same 
methods to move and copy that you use for worksheets in the same workbook . For 
example, with two workbooks arranged horizontally in the workspace, you can move 
a worksheet from one to the other by dragging it to the new location in the other 
workbook:

This removes the sheet from the source workbook and relocates it in the destination 
workbook; to copy it, press Ctrl while dragging . Note that you must arrange the two 
workbooks together on your screen to allow this to work . To do so, click the View tab 
on the ribbon, and then click the Arrange All button in the Window group and select 
an arrangement option (Horizontal in the illustration just shown) . 
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Viewing worksheets
Excel provides a few helpful features you can use to change the way worksheets are dis-
played. You can set up your workspace for specific tasks and then save the same view set-
tings for the next time you need to perform the same task.

Splitting worksheets into panes
Worksheet panes let you view different areas of your worksheet simultaneously. You can 
split any worksheet in a workbook vertically, horizontally, or both vertically and horizon-
tally and have synchronized scrolling capabilities in each pane. On the worksheet shown in 
Figure 6-17, columns B through M and rows 3 through 36 contain data. In Normal view, it’s 
impossible to see all the data at the same time.

Figure 6-17 You can scroll to display the totals in column N or row 38, but you won’t be able to 
see the headings.

You’ll find the 2014Projections.xlsx file with the other examples on the companion website.

It would be easier to navigate the worksheet in Figure 6-17 if it were split into panes. To 
do so, first select the cell where you want the split to happen, then click the View tab on 
the ribbon, and click the Split button in the Window group; the window divides into both 
vertical and horizontal panes simultaneously, as shown in Figure 6-18. When you rest your 
pointer on a split bar, it changes to a double-headed arrow.
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Figure 6-18 With the window split, you can scroll each pane independently.

Note
Before clicking Window, Split or double-clicking one of the split bar icons, select a cell 
in the worksheet where you want the split to occur . This splits the worksheet imme-
diately to the left or above the selected cell or both above and to the left . If cell A1 
is active, the split occurs in the center of the worksheet . In Figure 6-17, we selected 
cell B3 before choosing the Split command, which resulted in the split panes shown in 
 Figure 6-18 .

With the window split into four panes, as shown in Figure 6-18, four scroll bars are available 
(if not visible)—two for each direction. Now you can use the scroll bars to view columns 
B through N without losing sight of the product headings in column A. In addition, when 
you scroll vertically between rows 3 and 37, you always see the corresponding headings in 
row 2.

After a window is split, you can reposition the split bars by dragging. If you are ready to 
return your screen to its normal appearance, click the Split button again to remove all the 
split bars. You can also remove an individual split by double-clicking the split bar or by 
dragging the split bar to the top or right side of the window.

Freezing panes
After you split a window into panes, you can freeze the left panes, the top panes, or both 
panes by clicking the View tab on the ribbon, clicking Freeze Panes, and selecting the cor-
responding option, as shown in Figure 6-19. When you do so, you lock the data in the 
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frozen panes into place. As you can see in Figure 6-19, the pane divider lines have changed 
from thick, three-dimensional lines to thin lines.

Figure 6-19 Freezing panes locks the top pane, left pane, or both panes of a split window.

Note
You can split and freeze panes simultaneously at the selected cell by clicking Freeze 
Panes without first splitting the worksheet into panes. If you use this method, you 
simultaneously unfreeze and remove the panes when you click Unfreeze Panes . (The 
command name changes when panes are frozen .)

Notice also that in Figure 6-18, the sheet tab is invisible because the horizontal scroll bar is 
so large. After freezing the panes, as shown in Figure 6-19, the scroll bar returns to normal 
and the sheet tab reappears.

Note
To display another worksheet in the workbook if the sheet tabs are not visible, press 
Ctrl+Page Up to display the previous worksheet or Ctrl+Page Down to display the next 
worksheet .
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After you freeze panes, scrolling within each pane works differently. You cannot scroll the 
upper-left panes in any direction. In the upper-right pane only the columns can be scrolled 
(right and left) and in the lower-left pane only the rows can be scrolled (up and down). You 
can scroll the lower-right pane in either direction.

INSIDE OUT   Make frozen panes easier to see

Generally speaking, all the tasks you perform with panes work better when the win-
dows are frozen . Unfortunately, it’s harder to tell that the window is split when the 
panes are frozen because the thin, frozen-pane lines look just like cell borders . To make 
frozen panes easier to see, you can use a formatting clue that you will always recognize . 
For example, select all the heading rows and columns and fill them with a particular 
color .

Zooming worksheets
Use the Zoom controls in the bottom-right corner of the screen (or click the View tab and 
use the Zoom button) to change the size of your worksheet display. Clicking the Zoom 
button displays a dialog box containing one enlargement option, three reduction options, 
and a Fit Selection option that determines the necessary reduction or enlargement needed 
to display the currently selected cells. Use the Custom box to specify any zoom percent-
age from 10 through 400 percent. The Zoom To Selection button enlarges or reduces the 
size of the worksheet to make all the selected cells visible on the screen. Clicking Zoom To 
Selection with a single cell selected zooms to the maximum 400 percent, centered on the 
selected cell (as much as possible) in an attempt to fill the screen with the selection. 

Note
The Zoom command affects only the selected worksheets; therefore, if you group 
several worksheets before zooming, Excel displays all of them at the selected Zoom 
percentage . For more about grouping worksheets, see “Editing multiple worksheets” in 
Chapter 8 .

For example, to view the entire worksheet shown in Figure 6-17, you can try different zoom 
percentages until you get the results you want. Better still, select the entire active area of 
the worksheet, and then click the Zoom To Selection button. Now the entire worksheet 
appears on the screen, as shown in Figure 6-20. Note that the zoom percentage resulting 
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from clicking Zoom To Selection is displayed next to the Zoom control at the bottom of the 
screen.

Figure 6-20 Click the Zoom To Selection button with the active area selected to view it all on the 
screen.

INSIDE OUT   Quick maximum zooming

If you have only one cell selected in the worksheet, the Zoom To Selection button in 
the Zoom area of the View tab serves as a “Zoom Maximum” button, which enlarges 
the worksheet to 400%, its maximum possible size .

Of course, reading the numbers might be a problem when your worksheet is zoomed “far 
out,” but you can select other reduction or enlargement sizes for that purpose. The Zoom 
option in effect when you save the worksheet is the displayed setting when you reopen the 
worksheet.
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Note
The wheel on a mouse ordinarily scrolls the worksheet . You can also use the wheel to 
zoom . Simply hold down the Ctrl key and rotate the wheel . If you prefer, you can make 
zooming the default behavior of the wheel . To do so, click the File tab, click Options, 
select the Advanced category, and select the Zoom On Roll With IntelliMouse check 
box in the Editing Options area .

Using custom views
Suppose you want your worksheet to have particular display and print settings for one pur-
pose, such as editing, but different display and print settings for another purpose, such as 
an on-screen presentation. By clicking the Custom Views button on the View tab, you can 
assign names to specific view settings, which include column widths, row heights, display 
options, window size, position on the screen, pane settings, the cells that are selected at the 
time the view is created, and, optionally, print and filter settings. You can then select your 
saved view settings whenever you need them rather than manually configuring the settings 
each time.

Note
Before you modify your view settings for a particular purpose, you should save the 
current view as a custom view named Normal . This provides you with an easy way to 
return to the regular, unmodified view. Otherwise, you would have to retrace all your 
steps to return all the view settings to normal .

In the Custom Views dialog box, the Views list is empty until you click Add to save a custom 
view. All your custom views are saved with the workbook. Figure 6-21 shows the Custom 
Views dialog box with two views added, as well as the Add View dialog box you use to add 
them. 

Figure 6-21 Click Add to name the current view and print settings in the Custom Views 
dialog box.
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Protecting worksheets
In addition to password protection for your files, Excel offers several features that you 
can use to protect your work—workbooks, workbook structures, individual cells, graphic 
objects, charts, scenarios, windows, and more—from access or modification by others. You 
can also choose to allow specific editing actions on protected worksheets.

For information about additional security issues in Excel, see Chapter 4, “Security and privacy .”

By default, Excel locks (protects) all cells and charts, but the protection is unavailable until 
you activate it. Click the Review tab on the ribbon, and click Protect Sheet to access the 
Protect Sheet dialog box shown in Figure 6-22. (You can also click the Format button on 
the Home tab and then click Protect Sheet.) The protection status you specify applies to the 
current worksheet only.

After protection is turned on, you cannot change a locked item. If you try to change a 
locked item, Excel displays an error message. As you can see in Figure 6-22, the Allow All 
Users Of This Worksheet To list contains a number of specific editorial actions you can 
allow even on protected worksheets. In addition to the options visible in Figure 6-22, you 
can choose to allow users to sort, use Filter and PivotTable reports, and edit objects or 
scenarios.

Figure 6-22 The Protect Sheet dialog box gives you pinpoint control over many common 
editing actions.

Unlocking individual cells
If you click Protect Sheet without specifically unlocking individual cells, you lock every cell 
on the worksheet by default. Most of the time, however, you don’t want to lock every cell. 
For example, you might want to protect the formulas and formatting but leave particular 
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cells unlocked so that you can type necessary data without unlocking the entire worksheet. 
Before you protect a worksheet, select the cells you want to keep unlocked, click Format on 
the Home tab, and click Lock Cell, as shown in Figure 6-23. Lock Cell is selected by default 
for all cells, so clicking it clears it, unlocking the selected cells.

Figure 6-23 Click Format, Lock Cell to unlock specific cells for editing.

You can easily move between unprotected cells on a locked worksheet by pressing the 
Tab key.

One way to verify the locked status of a cell is to select it and look at the little padlock 
icon next to the Lock command. If the icon appears to be clicked already, it means that the 
selected cell is locked, which is the default state for all cells.

Note
You can tell if selected cells are locked by looking at the icon adjacent to the Lock Cell 
command . If the icon appears to be “pressed” like a button (as shown in Figure 6-23), 
the cells are locked . Keep in mind that Excel does not provide any other on-screen indi-
cation of the protection status for individual cells . To distinguish unlocked cells from 
protected cells, you might consider applying a specific format, such as cell color or 
borders .
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Protecting the workbook
You can prevent the alteration of a workbook’s structure and lock the position of the work-
book window. To do so, click the Review tab on the ribbon and click Protect Workbook to 
display the dialog box shown in Figure 6-24.

For more information, see “Protecting workbooks” in Chapter 7, “How to work a workbook .”

Figure 6-24 Use the Protect Structure And Windows dialog box to set the protection status for 
the entire workbook.

Allowing password access to specific cell ranges
If you need to do more than protect workbooks or individual worksheets, click Allow Users 
To Edit Ranges on the Review tab in the Changes group. Use the Allow Users To Edit Ranges 
dialog box, as shown in Figure 6-25, to provide editorial access to specific areas of a pro-
tected worksheet. You can even specify exactly who is allowed to do the editing.

Figure 6-25 You can specify cells that can be edited, as well as the individuals who are allowed 
to edit them, by using the Allow Users To Edit Ranges dialog box.
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When you click New in the Allow Users To Edit Ranges dialog box to add a cell range to the 
list, the New Range dialog box appears, as shown in Figure 6-26. Type a title for the range 
of cells you want to allow users to edit. Type a cell range or range name in the Refers To 
Cells box, or click in the box and drag through the range you want to specify.

Figure 6-26 Use the New Range dialog box to specify ranges you want to allow users to edit.

Selecting the Paste Permissions Information Into A New Workbook check box in the Allow 
Users To Edit Ranges dialog box is a handy way to keep track of who and what you speci-
fied in the Permissions list. Note that you can click the Protect Sheet button for quick access 
to the Protect Sheet dialog box shown earlier in Figure 6-22. You can click the Permissions 
button to specify individuals who are allowed to edit each range. When you do so, a dialog 
box like the one shown in Figure 6-27 appears.

Figure 6-27 Set permissions for individual users by clicking Permissions in the Allow Users To 
Edit Ranges dialog box.
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The Permissions dialog box lists all the users who are authorized to edit the worksheet, as 
well as whether they need to use a password to do so. For each item in the Group Or User 
Names list, you can specify password permissions in the box; click Allow or Deny to restrict 
editing without a password. This lets you, in effect, employ two levels of restriction, because 
you are restricting editing access to specified users anyway, and you can force even those 
users to type a password if you want to do so.

Note
You must specify a password in the New Range dialog box (shown in Figure 6-26) or in 
the identical Modify Range dialog box to turn on the permissions options that you set . 
If you don’t specify a range password, anyone can edit the range .

You can add users and groups to the list in the Permissions dialog box by clicking Add and 
then clicking Advanced to display the full dialog box shown in Figure 6-28. Click Find Now 
to locate all the users and groups available to your system. However, if you are connected 
to a large network, this might take a long time, so you can use the Common Queries area 
to restrict your search. You can also use the Object Types and Locations buttons to restrict 
your search further. After you click Find Now, you can select items in the list at the bottom 
of the dialog box that you want to add. Press the Ctrl key to select multiple items. When 
you have located the users and groups you want to add, click OK.

Note
To add or change users on your computer, open User Accounts in Control Panel .

Remember, after all this, you still have to activate worksheet protection by clicking Protect 
Sheet on the Home tab or by clicking Protect Sheet in the Allow Users To Edit Ranges dia-
log box.

For information about Excel and networks, see “Sharing workbooks on a network” in 
Chapter 26 .
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Figure 6-28 Click Add in the Permissions dialog box, and then click Advanced to select users to 
authorize.

Hiding cells and worksheets
In a protected worksheet, if you apply the Hidden protection format to a cell that contains 
a formula, the formula remains hidden from view in the formula bar even when you select 
that cell. To hide a selected cell or cells, click the Format button on the Home tab, and click 
Cells to display the Format Cells dialog box. Then click the Protection tab, and select the 
Hidden option. Formulas in hidden cells are still functional, of course; they are just hidden 
from view. In any case, the result of the formula is still visible on the worksheet.

For information about hiding numbers, see “The hidden number format” in Chapter 9 .

You can also hide rows and columns within a worksheet and even hide entire worksheets 
within a workbook. Any data or calculations in hidden rows, columns, or worksheets are 
still available through references; the cells or worksheets are simply hidden from view. To 
hide a worksheet, click the sheet tab to select the worksheet you want to hide. Then, on the 
Home tab, click Format, Hide & Unhide, Hide Sheet, as shown in Figure 6-29. Unlike hiding 
cells, hiding rows, columns, or worksheets happens immediately. Afterward, you can click 
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the corresponding Unhide command to restore the hidden item. However, if you hide a 
worksheet and then click Protect Workbook on the Review tab, the Unhide command is no 
longer available, which helps keep the hidden worksheet even better protected.

Figure 6-29 Use the Hide & Unhide commands to protect parts of your workbooks.

For more information about workbook protection, see “Hiding and protecting workbooks” in 
Chapter 7 .

Using passwords
When you click Protect Sheet, Protect Workbook, or Protect And Share Workbook on the 
Review tab, you can assign a password that must be used to disable the protection. You can 
use unique passwords for each worksheet or workbook you protect.

CAUTION!
Password protection in Excel is serious business . After you assign a password, you 
can’t unprotect the worksheet or workbook without it . Don’t forget your passwords! 
Remember, capitalization matters .




